Bug 46850 - iterative computation will not converge
Summary: iterative computation will not converge
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 RC2
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-01 14:21 UTC by jean-philippe.grivet
Modified: 2020-08-09 12:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example after one step (I can't attach two files) (8.90 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-01 14:21 UTC, jean-philippe.grivet
Details
Initial state of spreadsheet (8.85 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-01 14:23 UTC, jean-philippe.grivet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jean-philippe.grivet 2012-03-01 14:21:48 UTC
Created attachment 57878 [details]
example after one step (I can't attach two files)

I wish to solve the two dimensional Laplace equation by the relaxation method. To do this, I chose a region of the spread sheet enclosed in cells holding constant numerical values. Interior cells hold formulas like, for B2: =(B1+B3+A2+C2)/4. 
See Laplace0.ods; This amounts to a large number of circular references. I check iteration, chose step number 1, error bound 0.1, uncheck automatic calculation and press F9; I get Laplace1.ods, error 523 in every variable cell. Changing step number or error bound makes no difference. In contrast, the one-dimensional case (as in the help for circular reference) works well. What do I do wrong ?
Related question: once the computation stops, with error 523, how can I restart it without retyping the speadsheet?
Remark: Over the years, I have run this type of computation successfully on Quattro pro (!), Excel and OpenOffice.calc
Comment 1 jean-philippe.grivet 2012-03-01 14:23:14 UTC
Created attachment 57879 [details]
Initial state of spreadsheet
Comment 2 Kevin Suo 2014-06-26 08:11:08 UTC
This bug is never confirmed. Set to UNCONFIRMED.
Comment 3 Kevin Suo 2014-07-07 15:32:07 UTC
Hi jean-philippe.grivet,

As I am not expert on iterative computation, would you please take a look it bug 46845 to see if this one is a duplicate?

Thanks!
Comment 4 jean-philippe.grivet 2014-07-07 20:09:10 UTC
Le 07/07/2014 17:32, bugzilla-daemon@freedesktop.org a écrit :
> Kevin Suo <mailto:suokunlong@gmail.com> changed bug 46850 
> <https://bugs.freedesktop.org/show_bug.cgi?id=46850>
> What 	Removed 	Added
> See Also 		https://bugs.freedesktop.org/show_bug.cgi?id=46845
>
> *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=46850#c3> 
> on bug 46850 <https://bugs.freedesktop.org/show_bug.cgi?id=46850> from 
> Kevin Suo <mailto:suokunlong@gmail.com> *
> Hi jean-philippe.grivet,
>
> As I am not expert on iterative computation, would you please take a look it
> bug 46845  <show_bug.cgi?id=46845>  to see if this one is a duplicate?
>
> Thanks!
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
That's quite possible, although it is impossible to conclude since kevin 
gives no details of his computation
JJP Grivet


---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com
Comment 5 Jean-Baptiste Faure 2014-07-20 20:56:21 UTC
Not reproducible for me with versions 4.1.6, 4.2.7.0.0+ and 4.3.1.0.0+ under Ubuntu 14.04 x86-64. If I modify steps number to 10, I do not get an error and the computation converges.

You can restart the computation by reloading the file

Please, could you try again with current stable version? 
Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations.

Best regards. JBF
Comment 6 QA Administrators 2015-02-19 04:34:32 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 7 Jean-Baptiste Faure 2015-02-20 06:10:32 UTC
Still works (see comment #5) in LibreOffice 4.4.2.0.0+ under Ubuntu 14.10 x86-64

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF
Comment 8 b. 2019-12-27 12:30:40 UTC
still wfm, 

(but iteration in calc isn't 'clean') 

two comments on the initial report: 

> Changing step number or error bound makes no difference. 

wrong, it does, if you set steps to 1000 (lower values will work too) you'll get results, if you change 'error bound' or 'minimum change' to e.g. 0,5 in your sample you'll see results, 

> once the computation stops, with error 523, how can I restart it without retyping the speadsheet?

retype F9, ctrl-shift-F9 or whatever, err:523 doesn't 'stop' the calculation, it's only an error message displayed for results whose changes exceed the given limit. the calculations are! done, and their results are! used for the next round. as your equations converge results will show up after some steps, once the change - per step - is lower than the given limit. 

reg. 

b.
Comment 9 b. 2020-08-09 12:01:49 UTC
just spotted on a recheck: 

ver 6.1.6.3 is stuck in err:523, ver 7.1.0.0 calculates, 

iterative calculations are 'off' from undo, 

same in ex$el, 

ex$el does! a new round of calculation for circular dependent formulas on changes elsewhere in the sheet, while calc doesn't,