Bug 46924 - UI: add toolbar commands pane shrinks, disappears
Summary: UI: add toolbar commands pane shrinks, disappears
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-03 02:52 UTC by Satchit Bhogle
Modified: 2012-03-03 07:59 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of problem (53.52 KB, image/png)
2012-03-03 02:52 UTC, Satchit Bhogle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Satchit Bhogle 2012-03-03 02:52:37 UTC
Created attachment 57964 [details]
Screenshot of problem

Problem description: 
See steps and attached image.

Steps to reproduce:
1. Go to Tools > Customise > Toolbars, and click Add.
2. Move to a toolbar that does not have enough elements to fill the pane, e.g. Data. Now back to something that has, e.g. Application.
3. Keep switching between toolbars.
4. Watch the commands pane gradually shrink and then disappear.

Current behavior:
The pane shrinks for toolbars with fewer elements and then stays shrunk when going to a toolbar with more elements.

Expected behavior:
The pane remains the same size regardless.


Platform (if different from the browser): 
Ubuntu 11.10 Oneiric stable 32-bit

Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Comment 1 Björn Michaelsen 2012-03-03 06:32:21 UTC
_NOT_ reproducable at upstream libreoffice-3-5 branch-off without Ubuntus default theme.
reproducable with 1:3.5.0-1ubuntu4 with Ubuntus theme.
Comment 2 Björn Michaelsen 2012-03-03 07:48:14 UTC
Also not reproducable on upstream master (1cf3e446744ae679bc89b39dcbbcf6b4e9821f3a) without default Ubuntu theming on oneiric.
Also not reproducable on 3.4.5 Ubuntu build on oneiric.

This seems to be a regression between oneiric->precise in either Ubuntus theme or stack (gtk?)

resolving here as not our bug.
Comment 3 Björn Michaelsen 2012-03-03 07:59:16 UTC
Of course, it could well be that it is a bug in the libreoffice gtk-vcl plugin which only shows with recent versions of gtk. In that case, please reopen.

@Fedora, SUSE user: Can you reproduce this with a very new gtk? The issie is visible here with gtk+-2.24.10-0ubuntu4