Download it now!
Bug 46986 - Hyperlink is repositioned in document after opening in browser
Summary: Hyperlink is repositioned in document after opening in browser
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyperlink
  Show dependency treegraph
 
Reported: 2012-03-05 16:14 UTC by snowshed1
Modified: 2017-11-05 19:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description snowshed1 2012-03-05 16:14:53 UTC
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

Firefox 10.0.2

OS X 10.6.8

If you are a user of the Spaces feature on a Mac, when you follow the steps below, please make sure the new writer document and your browser are in the same space.  If the document and the browser are in different spaces, the bug is apparently not reproducible.

Steps to reproduce:

1) Open a new document in Writer.
2) Enter X number of blank lines using the Return key.
3) Insert a hyperlink in one of the blank lines.
4) Click on the hyperlink, causing the link to open in your browser.
5) Return to the Writer document by clicking on a blank line in the document.
6) The hyperlink in the document is moved to the blank line you clicked.


If you have a page of text, a table, apparently anything, the hyperlink will be moved to the spot where you click in the document.

Please feel free to ask for clarification, and if you would like me to try specific steps.
Comment 1 lauregl 2012-04-19 04:43:30 UTC
[Reproducible] with LO 3.5.2 on OSX 10.7.3
Comment 2 Roman Eisele 2012-08-31 14:26:03 UTC
REPRODUCIBLE with LibreOffice 3.6.1.2 (Build ID: e29a214), German langpack installed, on Mac OS X 10.6.8 (Intel). Following the steps given by the reporter gives exactly the same result. (Not using Spaces.)

And already
REPRODUCIBLE with LibreOffice 3.3.0 on the same machine.

-> Adapting Version information (NB: the version field should always contain the number of the 1st version in which a bug is reproducible, not the last one!).
Comment 3 V Stuart Foote 2013-05-05 16:23:15 UTC
WFM, on Win 7 sp1, 64-bit on LibreOffice 4.0.3, 
and LibODev 4.1.0 (TB 6 of 2013-04-29)

adding to bug 42082 meta-bug
Comment 4 QA Administrators 2015-03-04 02:23:07 UTC Comment hidden (obsolete)
Comment 5 Alex Thurgood 2015-03-25 16:15:59 UTC
Still present in 

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale : fr_
Comment 6 QA Administrators 2016-09-20 10:11:54 UTC Comment hidden (obsolete)
Comment 7 eisa01 2017-11-05 19:40:58 UTC
This works for me now, was present in original 3.3

Version: 6.0.0.0.alpha1+
Build ID: 7e03c4eed72452fdfb87341214a21956c08ba969
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-25_23:45:02
Locale: en-US (en_US.UTF-8); Calc: group