Download it now!
Bug 47319 - Crash when double-clicking a shape
Summary: Crash when double-clicking a shape
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 41620 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-14 13:43 UTC by Olivier Berten
Modified: 2012-03-23 09:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (8.69 KB, application/vnd.oasis.opendocument.text)
2012-03-15 23:59 UTC, Olivier Berten
Details
Bt with 3.5 branch (3.23 KB, text/plain)
2012-03-17 05:14 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Berten 2012-03-14 13:43:10 UTC
If you double-click a shape drawn (partly) above the top margin, LO will crash.
Comment 1 Julien Nabet 2012-03-15 15:04:29 UTC
On pc Debian x86-64 with 3.5 branch (so not exactly 3.5.0), I can't reproduce this problem.

Do you reproduce with any brand new document or is it only with some specific documents ?
If only specific documents, did they been created by LO or other Office program ? With which version ?  
Could you attach a document ?
Comment 2 Olivier Berten 2012-03-15 23:59:17 UTC
Created attachment 58538 [details]
Test document
Comment 3 Olivier Berten 2012-03-16 00:04:21 UTC
I discovered this with a MSO template (dot) but I can reproduce it with any newly created doc.

In the test document attached, whenever I double-click on the rectangle at any point above the margin, LO crashes.

I'm using the 1:3.5.0-1ubuntu3~oneiric1 package from https://launchpad.net/~libreoffice/+archive/ppa on Ubuntu 11.10 64-bit.
Comment 4 Korrawit Pruegsanusak 2012-03-17 02:46:07 UTC
[No crash] with 3.5.0 RC2 / WinXP with the attached document in comment 2.

Maybe Ubuntu specific?
Comment 5 Julien Nabet 2012-03-17 05:14:48 UTC
Created attachment 58596 [details]
Bt with 3.5 branch

On Debian x86-64, I reproduced it on 3.5 branch (last commit 90e2949099586e98619561dc781cc4deb8fc1ef0), see bt.


Then I updated 3.5 branch (c39e96d984b5907f8e0c0247828c8e35f2e9ce72), I didn't reproduce it !

On master branch (updated today), I don't reproduce it too, just noticed this message :
warn:sfx2.appl:25528:1:/home/julien/compile-libreoffice/libo/sfx2/source/appl/module.cxx:396: SfxModule::GetFieldUnit: no metric item in the module implemented by '8SwModule'

So it seems it should be ok for 3.5.2 (see http://wiki.documentfoundation.org/ReleasePlan/3.5)
Comment 6 Petr Mladek 2012-03-20 08:32:18 UTC
I am not able to reproduce this with last build that is almost 3.5.2-rc1. The comments from Julien sound promissing that it really might be fixed there => closing the bug for now.

Feel free to reopen it if you see the problem again with 3.5.2 or newer.


PS: It see the new header line blinking under the box. It might be related to this new feature => adding Cedric into CC.
Comment 7 Petr Mladek 2012-03-23 09:57:47 UTC
*** Bug 41620 has been marked as a duplicate of this bug. ***