Bug 47385 - FORMATTING: There is no easy way to exclude or include a format in a page format
Summary: FORMATTING: There is no easy way to exclude or include a format in a page format
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Writer-Styles-Page
  Show dependency treegraph
 
Reported: 2012-03-15 19:34 UTC by stragu
Modified: 2017-08-11 15:03 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stragu 2012-03-15 19:34:09 UTC
Problem description:
If you want to organise your document with one kind of content on left pages and another content on right pages, there is no easy way to do it.
An example can be a scientific publication where one wants to organise the text on the right pages and the illustrations on the left pages.

Current behavior:
There is no easy way to link a format to another one so when this format is chosen (for example, text body and headings) it only appears included into the other format (for example, left page or right page).

Expected behavior:
There should be an option in the "organiser" tab of the format style window that says "include in" and "exclude in". This way, one could choose for example to include the "text body" and "heading" formats only into the "right page" format, and the "graphics" and "frame" formats only into the "left page" format, so when the user is writing, the text jumps automatically form right page to right page.
Of course, many other possibilities are imaginable.

Platform (if different from the browser):
Ubuntu 11.10
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0

Complement:
Related question on Ask LibreOffice: http://ask.libreoffice.org/question/461/is-there-a-way-to-colour-a-series-of-cells-with
Comment 1 stragu 2012-03-19 06:02:50 UTC
Sorry, related question on Ask LibreOffice is this one:
http://ask.libreoffice.org/question/937/illustrations-on-left-pages-and-text-on-right
Comment 2 Yousuf Philips (jay) (retired) 2017-06-17 13:37:06 UTC
Hi stragu,

Having particular paragraph or frame styles apply or not apply based on whether they appear in an assigned list of a page style seems like a very complex feature that LibreOffice shouldnt be implementing.

So for example when text set to 'Heading 1' paragraph style isnt supposed to appear on the 'left page' style, what paragraph style does that text appear as?

In my view, document author's should style and un-style text and objects according to how they want it to appear in their finalized document and not rely on LibreOffice to automate it in complex ways. So WONTFIX for me.

Regina: Is this something that conditional formatting can solve?

UX-Team: Your thoughts?
Comment 3 Cor Nouws 2017-06-19 13:20:38 UTC
it's a nice idea, but indeed way too complex if you make it full functional.

A 'basic' version, where you have e.g. headings left and the paragraphs that follow right, may be easier?

 [left page]  [right page]
 - - - - - - - - - - - - - 
 |           |           |
 | 1stheading| text text |
 |           | text text |
 |           | text text |
 |           | text text |
 |           | text text |
 |           |           |
 | heading2  | text text |
 |           | text text |
 |           |           |
 - - - - - - - - - - - - -
Comment 4 Yousuf Philips (jay) (retired) 2017-06-20 14:57:15 UTC
So lets close as WONTFIX.

If others in UX-Team disagree, please reopen.
Comment 5 stragu 2017-07-12 04:54:34 UTC
Hi folks

Thank you for commenting.

I don't want to re-open, but I was wondering if you could answer this:

Given that it is a pretty common requirement to layout a document so pictures are on one side and text on the other, how would you go about automating that? No one likes "artificially" going through the final version of 100-page document inserting countless page breaks and aligning the pictures on the left with the corresponding paragraph on the right (especially since modifying that document will mess the layout up and require to do it all over again).

The workaround I found ( https://ask.libreoffice.org/en/question/937/illustrations-on-left-pages-and-text-on-right-pages/?answer=1377#post-id-1377 ) is clearly not ideal, it is using the "next style" feature to create left and right pages styles, and it is using a "header" that takes up the whole of the page in one of the styles so the text never makes it into those pages.
The least elegant thing I've ever come up with, really.
Comment 6 Cor Nouws 2017-08-11 15:03:01 UTC
Hi Stephane,

(In reply to stragu from comment #5)

> Given that it is a pretty common requirement to layout a document so
> pictures are on one side and text on the other, how would you go about
> automating that? ...

To be honest, it's (AFAIR) for the first time in ~20 years that I read about this as being a must have.
But.. I would simply suggest proper user handling:
- 2 pages side by side
- to empty paragraphs on the left one, Ctrl+Enter to go to the right one
- return to left one and insert images as needed (possibly using frame styles).

No fancy / (semi) automated stuff available, indeed, AFAIK

ciao - Cor