Download it now!
Bug 47439 - [SVG] linear gradients are not handled properly
Summary: [SVG] linear gradients are not handled properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 115592 (view as bug list)
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2012-03-17 06:33 UTC by Valek Filippov
Modified: 2018-06-20 17:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
SVG file for test (4.68 KB, image/svg+xml)
2012-03-17 06:33 UTC, Valek Filippov
Details
How it should look like (31.03 KB, image/png)
2012-03-17 06:33 UTC, Valek Filippov
Details
Result with lodraw 3.5.1 release (2.28 KB, image/png)
2012-03-17 06:34 UTC, Valek Filippov
Details
Good view of gradients in 6.0.4 (72.27 KB, image/png)
2018-06-16 15:13 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valek Filippov 2012-03-17 06:33:23 UTC
Created attachment 58599 [details]
SVG file for test

How to reproduce
----------------
1. Open attached SVG file.
2. Insert attached SVG file into the same document
("Insert->Picture->From file...").

Expected results
----------------
Both pictures look the same.

Results with lodraw 3.5.1 release
---------------------------------
1. Horizontal linear gradient (right-left) was converted into vertical (down-up).
2. Gradient position was ignored.
3. Only first two colour stops seem to be taken.

(Text is missed, but I'm going to open another bug(s) for text issues with SVG "Open").
Comment 1 Valek Filippov 2012-03-17 06:33:55 UTC
Created attachment 58600 [details]
How it should look like
Comment 2 Valek Filippov 2012-03-17 06:34:31 UTC
Created attachment 58601 [details]
Result with lodraw 3.5.1 release
Comment 3 sasha.libreoffice 2012-06-12 01:50:24 UTC
Thanks for bugreport
in 3.3.4 on Fedora: Insert->Picture->From file and File->Open shows problem with gradients, no text

in 3.5.4 on Fedora: 
Insert->Picture->From file - all correct
File->Open - problem with gradients, no text

in 3.5.2 on Windows 7:
Insert->Picture->From file - gradients correct, empty rectangles instead of characters
File->Open - problem with gradients, no text

So, Insert->Picture->From file is fixed, bug File->Open still has bug
Comment 4 Thomas Arnhold 2013-10-14 23:27:57 UTC
NOT reproducible anymore on Windows 7:

Version: 4.1.2.3
Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
Comment 5 sasha.libreoffice 2013-10-15 07:55:49 UTC
Thanks for additional testing.

Problem still reproducible in 4.1.2.3 on Fedora (RFR) 64 bit and Windows 8 64 bit using File->Open in LO menu.

Changing status to New
Comment 6 A (Andy) 2015-04-05 21:18:05 UTC
Reproducible with LO 4.4.1.2 (Win 8.1): 
- Horizontal linear gradient (right-left) was converted into vertical (down-up)
- Wrong gradient position
- Problems with more than two gradient colours (?)
- Missing text
Comment 7 Robinson Tryon (qubit) 2015-12-09 18:52:46 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-01-03 19:40:01 UTC Comment hidden (obsolete)
Comment 9 Heiko Tietze 2018-03-28 10:09:03 UTC
*** Bug 115592 has been marked as a duplicate of this bug. ***
Comment 10 Roman Kuznetsov 2018-06-16 15:13:23 UTC
Created attachment 142801 [details]
Good view of gradients in 6.0.4

I used menu Insert->Image for import SVG. Result in attach. Looks very good, imho