Download it now!
Bug 47445 - [SVG] patterns are not handled properly
Summary: [SVG] patterns are not handled properly
Status: RESOLVED DUPLICATE of bug 34720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2012-03-17 09:46 UTC by Valek Filippov
Modified: 2018-06-20 17:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Testing file (158.39 KB, image/svg+xml)
2012-03-17 09:46 UTC, Valek Filippov
Details
Screenshot of the file opened and inserted in lodraw 3.5.1 (61.56 KB, image/png)
2012-03-17 09:48 UTC, Valek Filippov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valek Filippov 2012-03-17 09:46:30 UTC
Created attachment 58611 [details]
Testing file

How to reproduce
----------------
1. Open attached SVG file.
2. Insert attached SVG file into the same document
("Insert->Picture->From file...").

Expected results
----------------
Both pictures look the same.

Results with lodraw 3.5.1 release
---------------------------------
1. Pattern is not applied to rectangle.
2. Bitmap patterns are imported as separate rectangles and placed in the top left corner.
(On the screenshot I've moved one bitmap (not used by any shape, but stored in the file) to show another bitmap under it.)
Comment 1 Valek Filippov 2012-03-17 09:48:19 UTC
Created attachment 58612 [details]
Screenshot of the file opened and inserted in lodraw 3.5.1
Comment 2 sasha.libreoffice 2012-06-12 02:02:53 UTC
Thanks for bugreport
result on Fedora 64 bit:
in 3.3.4: Insert->Picture->From file and File->Open shows bug
in 3.5.4: Insert->Picture->From file works correctly
File->Open show bug
(Windows not tested, expected the same result)
Comment 3 Thomas Arnhold 2013-10-14 23:30:41 UTC
NOT reproducible anymore with

Version: 4.1.2.3
Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
Comment 4 sasha.libreoffice 2013-10-15 08:01:52 UTC
Textures still in wrong place
Reproduced in 4.1.2.3 on Fedora (RFR) 64 bit using File->Open
Changing status to New
Comment 5 A (Andy) 2015-04-05 20:48:17 UTC
Reproducible with LO 4.4.1.2, Win 8.1

The textured rectangles are not shown correctly (you can only see two black filled rectangles).  
I think this is maybe the same problem as in Bug 34720?  Maybe a duplicate of it?
Comment 6 Xisco Faulí 2015-11-10 16:06:58 UTC

*** This bug has been marked as a duplicate of bug 34720 ***
Comment 7 Robinson Tryon (qubit) 2015-12-17 05:48:18 UTC
Migrating Whiteboard tags to Keywords: (filter:svgOpen)
[NinjaEdit]