Bug Hunting Session
Bug 47496 - Saving a DBF (dBase) after Editing values changes the column data format: adds trailing decimals (FILESAVE,FORMATTING)
Summary: Saving a DBF (dBase) after Editing values changes the column data format: add...
Status: RESOLVED DUPLICATE of bug 32672
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 33511 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-19 03:23 UTC by a.lo
Modified: 2017-06-17 11:33 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Original file, correct. Created using openoffice 3.3 (3.99 KB, application/x-dbase)
2012-03-19 03:23 UTC, a.lo
Details
same file, saved by libreoffice. Column data structure has been modified. (File is Iso-8859-15 or winlatin1) (3.88 KB, application/x-dbase)
2012-03-19 03:25 UTC, a.lo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a.lo 2012-03-19 03:23:21 UTC
Created attachment 58668 [details]
Original file, correct. Created using openoffice 3.3

first of all, this bug may be related to https://www.libreoffice.org/bugzilla/show_bug.cgi?id=32672, but it's a little different.

Saving a .dbf file changes the columns datatype. Trailing decimals are ALWAYS added.

There is no way to stop this. I tried saving in different charsets, changing the spreadshell cell format to whole numbers before saving, etc. Two trailing decimals are always added.

I.E. COLUMN,N,5,0 becomes COLUMN,N,7,2 and 1995 becomes 1995,00

This bug did not occur in Openoffice between March 2009 up to Version 3.3(including)


The reformatting seems to occure during filesave, not during opening the modified file.:
Opening a saved file and saving it again leads to a binary identical (modified) file.
Comment 1 a.lo 2012-03-19 03:25:45 UTC
Created attachment 58669 [details]
same file, saved by libreoffice. Column data structure has been modified. (File is Iso-8859-15 or winlatin1)
Comment 2 Florian Reisinger 2012-05-19 10:42:08 UTC
Please do not use https://www.libreoffice.org/bugzilla/*, use https://bugs.freedesktop.org/* URLs instead..
Thanks

Florian R.
Comment 3 Urmas 2012-08-14 17:18:20 UTC
*** Bug 33511 has been marked as a duplicate of this bug. ***
Comment 4 Tonal 2012-08-15 15:54:04 UTC
I do not open first attachment file from Calc - General InOut error.
Also do not save furst example from Bug 33511 - General InOut error.
Os: Kubuntu 12.04 with last LO from Kubuntu repositories: LibreOffice 3.5.4.2 350m1(Build:2)
Comment 5 alister.hood 2012-11-15 05:59:11 UTC
> I do not open first attachment file from Calc - General InOut error.
> Also do not save furst example from Bug 33511 - General InOut error.

It works OK for me (on Arch).
Maybe try again?
Comment 6 agiucar 2012-12-07 15:46:18 UTC
Ho lo stesso problema.
I campi numerici non conservano il formato originale.

agiucar
Comment 7 Alex Thurgood 2013-07-11 10:28:59 UTC
This looks like a DUP of bug 32672 to me, since the output header becomes the same as the one mentioned in that report.

Adding Kohei to CC.


Alex
Comment 8 Björn Michaelsen 2014-01-17 00:43:28 UTC Comment hidden (obsolete)
Comment 9 Joel Madero 2015-05-02 15:43:57 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2016-09-20 09:37:43 UTC Comment hidden (obsolete)
Comment 11 Julien Nabet 2017-06-11 20:26:57 UTC
Following Alex's comment, any better with recent LO version? (last stable one is 5.3.3).
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce this. (perhaps I missed something?)
Comment 12 Julien Nabet 2017-06-17 11:33:25 UTC
Symptoms described are indeed the same as tdf#32672.

If I'm wrong and someone still reproduces this with a recent LO version (5.2.7 or 5.3.3), don't hesitate to reopen this tracker.

*** This bug has been marked as a duplicate of bug 32672 ***