Bug 47663 - BUGZILLAASSISTANT: After finishing the bug submittal, show a invitation to join QA
Summary: BUGZILLAASSISTANT: After finishing the bug submittal, show a invitation to jo...
Status: RESOLVED DUPLICATE of bug 57199
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, topicQA
Depends on:
Blocks:
 
Reported: 2012-03-21 07:52 UTC by Björn Michaelsen
Modified: 2015-12-16 05:14 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2012-03-21 07:52:45 UTC
After a bug has been successfully filed a screen should show an invitation to join LibreOffice QA and a link to:
https://wiki.documentfoundation.org/QA
Comment 1 Rainer Bielefeld Retired 2012-03-22 23:51:03 UTC
I do not believe that we should do so.

a) there is nothing that can be joined. The "QA-Team" is less than fiction, and it means nothing whether oyu are on the list or not. Most active reviewers are not on the list

b) Currently we have no inviting description what "QA-Team" does, why it might be useful to do bug reviews or to report bugs. A first step should be to create such invitation.

c) I believe that would be too persisting. Many users who reported a bug the first time in their life are not in the mood to start activity to contribute to LibO. They are angry, lost time, may be data, want to tell about their frustration, and they might see it as an impudence that now LibO asks for their contributions.  

d) We should try to get competent people, not masses of people. I believe a personal invitation would be more promising than mass advertising
Comment 2 Björn Michaelsen 2012-03-23 05:11:00 UTC
cc'ing mmeeks as community founding maestro.
a) The only way to change that is to create one and we need recruiting for that. Also we have a list and a call -- which all we need to grow from.
b) Indeed the QA wiki page might need to cosmetics to be more inviting to newcomers. But that is mostly independent of this.
c) I dont think so. Most users dont file bugs at all (or only file then against their Linux distro). Someone who got a freedesktop bugzilla account already shows some real interest in contributing -- something we should encourage. And those who are angry and just want to vent of steam without wanting to contribute are not a loss.
d) We need both and you generate competent people from motivated newcomers -- those do not grow on trees. Also just like there are "easy hacks" to get started in development (for example: "translating comments"), there are "easy hacks" for QA: confirming bugs for example. We need to get people get started -- they will  grow their competence along the way and will get able to support us with more and more complex tasks.

Michael: Do you concur here?
Comment 3 Michael Meeks 2012-03-23 06:37:03 UTC
Lets discuss at the ESC :-) I think you're both right personally. Someone needs to write some web-page with concrete tasks on "how to be a kick-ass QA guy and help Rainer" ;-) it's prolly not you Rainer - I imagine it seems obvious to you.

I like the idea of making confirming bugs a beginner task, but I suspect we'd want 2x extra confirmations from newbies instead of just one from an experienced QA guy (or something).

Either way - lots to discuss; sorry I can't be on the call later...
Comment 4 Rainer Bielefeld Retired 2012-03-23 09:38:38 UTC
May be it will be frustrating for a beginner to see 1000 Unconfirmed/Needinfo bugs, not understanding at all what to do
I am thinking about a query with hand-picked beginner suitable bugs that 
- have a good description how to reproduce
- do not need too much knowledge, but some study
Additionally we need an inviting short Wiki instruction "How to do my first bug confirmation".

If these conditions are fulfilled I believe we can do that demand after the bug submission in the assistant, and we can hope that a sense of achievement might encourage the user to try more confirmations or other contribution.

I believe that query should not be too complicated, I will contribute an idea next week.
Comment 5 Björn Michaelsen 2012-05-18 10:53:23 UTC
@Rainer: IIRC manually updating a query proved to much work, right? If so, IMHO we should just go with a broad/not-preselected query as:
a) we cant loose anything with that
b) we might win some contributors
Comment 6 Rob Snelders 2012-11-23 19:00:19 UTC

*** This bug has been marked as a duplicate of bug 57199 ***
Comment 7 Robinson Tryon (qubit) 2015-12-16 05:14:39 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner TopicQA)
[NinjaEdit]