Bug Hunting Session
Bug 47716 - XLSX - Import ignores page layout
Summary: XLSX - Import ignores page layout
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-22 06:01 UTC by Christian Ehrlicher
Modified: 2016-01-19 08:38 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Testfiles to show the problem (A3 & A4 portrait/landscape) (24.38 KB, application/zip)
2012-03-22 06:01 UTC, Christian Ehrlicher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ehrlicher 2012-03-22 06:01:57 UTC
Created attachment 58866 [details]
Testfiles to show the problem (A3 & A4 portrait/landscape)

The page layout of an imported xlsx (Office 2010) - file is not recognized and defaulted back to a random value. When using xls (Office 2003), the page layout is correct. 

I've attached some xlsx - files to show the problem.
Comment 1 s-joyemusequna 2012-03-22 10:39:37 UTC
Confirmed. Tested on Windows XP / Vista64.

Works fine with Word 2007 and OpenOffice.org 3.1 (no newer version installed).

Does not work with LibO 3.3.4, 3.4.5, and 3.5.2 RC1 (random value here, mostly portrait).

This is a regression.
Comment 2 Markus Mohrhard 2012-04-24 08:14:13 UTC
If it did not work in 3.3.4 it is not a regression.
Comment 3 retired 2014-12-27 12:38:35 UTC
OSX 10.10.1 LO 4.4RC1 persisting.
Excel 2011 prints a landscape file while LO prints a portrait file.
Comment 4 QA Administrators 2016-01-17 20:05:35 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 5 Christian Ehrlicher 2016-01-18 19:06:24 UTC
I completly forgot about this patch... Checked the attached excel-files and with lo 5.0.4 everything is fine. :)
Comment 6 steve -_- 2016-01-19 08:38:11 UTC
Since we don't have a specific patch fixing this issue, setting to WORKSFORME. Thanks Christian for re-testing and updating this bug.