Bug 47736 - SPELL: English spell check offers Spanish replacement options
Summary: SPELL: English spell check offers Spanish replacement options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: BSA target:3.6.0 target:3.5.2
Keywords:
: 46826 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-22 14:58 UTC by achimes
Modified: 2012-05-09 11:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LO offers Spanish words as alternative to misspelled English word (7.53 KB, image/png)
2012-03-22 14:58 UTC, achimes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description achimes 2012-03-22 14:58:14 UTC
Created attachment 58891 [details]
LO offers Spanish words as alternative to misspelled English word

Problem description: Spell check offers Spanish alternatives along with English for misspelled words.

Steps to reproduce:
1. Misspell word, which will be flagged by red underscore.
2. Right-click on misspelled word.
3. Observe pop-up which may include Spanish "corrections" along with English words. See attached image

"Text Language" is set for "English (USA)"

LibreOffice 3.5.1.2, Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66

Current behavior:

Expected behavior:

Platform (if different from the browser): Windows 7 Professional 64, 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.79 Safari/535.11
Comment 1 Not Assigned 2012-03-23 06:42:36 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=6299bf66e3004cb8db805b360070762d0870cf50

fdo#47736 typo
Comment 2 Not Assigned 2012-03-23 09:50:24 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=6845e5260eecb400953442f14170339327af01ee&g=libreoffice-3-5

fdo#47736 typo


It will be available in LibreOffice 3.5.3.
Comment 3 manj_k 2012-03-23 14:56:50 UTC
*** Bug 46826 has been marked as a duplicate of this bug. ***
Comment 4 Not Assigned 2012-03-26 02:57:54 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-2":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=976d287905accda35651052959cd85da073b9b24&g=libreoffice-3-5-2

fdo#47736 typo


It will be available already in LibreOffice 3.5.2.
Comment 5 Rainer Bielefeld Retired 2012-04-05 08:14:03 UTC
I added Fix submitter as assignee because this will ease queries and bug tracking.
Comment 6 Not Assigned 2012-05-09 11:17:54 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "feature/submodules":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=6299bf66e3004cb8db805b360070762d0870cf50&g=feature/submodules

fdo#47736 typo