Bug 47773 - EDITING embedded OLE EXCEL Spreadheet in particular .ppt moves view area after object has been left
Summary: EDITING embedded OLE EXCEL Spreadheet in particular .ppt moves view area afte...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OLE-Object-Interoperability
  Show dependency treegraph
 
Reported: 2012-03-23 08:05 UTC by sasha.libreoffice
Modified: 2021-10-02 05:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test case presentation with diagram (33.00 KB, application/vnd.ms-powerpoint)
2012-03-23 08:05 UTC, sasha.libreoffice
Details
the same presentation, saved as odp (34.29 KB, application/vnd.oasis.opendocument.presentation)
2012-03-23 08:22 UTC, sasha.libreoffice
Details
Calc OLE object loose viewport in Impress (27.32 KB, application/vnd.oasis.opendocument.presentation)
2012-07-31 17:02 UTC, Olivier Hallot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-03-23 08:05:10 UTC
Created attachment 58931 [details]
test case presentation with diagram

In attachment we have presentation with embedded Calc (Excel) object (Diagram)
Steps to reproduce:
0. Open attached document in Impress
1. Double click diagram
2. Click outside of Calc to return to Impress
Expected: diagram remains unchagned
Actually: size of diagram seriously changed, we can see only part of it

reproduced in 3.3.4 and 3.5.1 on Fedora 64 bit and Windows XP 32 bit
(in 3.3.4 diagram in step 0 not seen)
Problem remains if save presentation in odp format
Comment 1 sasha.libreoffice 2012-03-23 08:22:01 UTC
I have saved presentation in odp format and validated result on site:
http://www.probatron.org:8080/officeotron/officeotron.html
errors was:
 Forcing validation against ISO/IEC 26300
          (content.xml:2 col:5,591) attribute "href" from namespace "http://www.w3.org/1999/xlink" not allowed at this point; ignored
          (content.xml:2 col:5,591) attribute "type" from namespace "http://www.w3.org/1999/xlink" not allowed at this point; ignored
          (content.xml:2 col:6,603) element "coordinate-region" from namespace "http://openoffice.org/2010/chart" not allowed in this context
          (content.xml:2 col:7,589) attribute "axis-type" from namespace "http://openoffice.org/2010/chart" not allowed at this point; ignored
          (content.xml:2 col:7,611) element "date-scale" from namespace "http://openoffice.org/2010/chart" not allowed in this context
          (content.xml:2 col:8,698) element "desc" from namespace "urn:oasis:names:tc:opendocument:xmlns:svg-compatible:1.0" not allowed in this context
          (content.xml:2 col:8,857) element "desc" from namespace "urn:oasis:names:tc:opendocument:xmlns:svg-compatible:1.0" not allowed in this context
     The document is invalid
          (styles.xml:2 col:22,730) bad value for attribute "fit-to-size" from namespace "urn:oasis:names:tc:opendocument:xmlns:drawing:1.0"
     The document is invalid
Comment 2 sasha.libreoffice 2012-03-23 08:22:51 UTC
Created attachment 58934 [details]
the same presentation, saved as odp
Comment 3 Rainer Bielefeld Retired 2012-05-16 11:06:09 UTC
[Reproducible] with "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit) 
and
[Reproducible] with parallel installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 9980e69]" (tinderbox: Win-x86@6-fast, pull time 2012-05-10 09:36:56)

OOo 3.2 and AOOo do not show that problem, they open a readonly spreadsheet after double click on the OLE object (what IMHO is a really useless action).

I doubt that the compatibility test results have to do with that problem.


@Thorsten:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 4 Olivier Hallot 2012-07-31 17:01:05 UTC
On another issue related to Calc OLE objetcts inserted into Impress, I cannot control the size of the displayed object.

On the first insert, it looks like you can set the size and the contents/viewport of the spreadsheet. But on opening the presentation a second time with data in Calc updated, the OLE object looses the viewport, and compress a whole Calc page to fit into the OLE frame in impress.

OLE is flawed in Impress and almost unusable.

Linking spreadsheets into presentations is not a minor feature.

As an example, the attached presentation shows the issue: Slide 1 is Calc data inserted by Copy & Paste, and displays correctly. Slide 2 is data inserted through Insert - Object - OLE object, From File, and displays badly, with no control possible.
Comment 5 Olivier Hallot 2012-07-31 17:02:35 UTC
Created attachment 65008 [details]
Calc OLE object loose viewport in Impress

Slide 1 is the desired layout
Slide2 is what I get, after updating the spreadsheet.
Comment 6 A (Andy) 2013-04-27 09:55:49 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 7 QA Administrators 2015-04-19 03:23:44 UTC Comment hidden (obsolete)
Comment 8 tommy27 2015-06-16 19:51:26 UTC
retested under Wi8.1 x64 using LibO 4.4.3.2 and recente 5.1.0.0alpha
still reproducible
Comment 9 QA Administrators 2016-09-20 10:02:15 UTC Comment hidden (obsolete)
Comment 10 Thomas Lendo 2018-10-01 20:32:45 UTC
Still reproducible.

Version: 6.2.0.0.alpha0+
Build-ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: threaded
Comment 11 QA Administrators 2019-10-02 02:57:08 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2021-10-02 03:39:57 UTC Comment hidden (obsolete)
Comment 13 Rainer Bielefeld Retired 2021-10-02 05:25:18 UTC
😥