Bug Hunting Session
Bug 47798 - Localized LibreOffice Help files ignored when help for en-US is installed
Summary: Localized LibreOffice Help files ignored when help for en-US is installed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 02:51 UTC by Gabor Kelemen
Modified: 2013-10-30 00:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem (42.58 KB, image/png)
2012-03-24 02:51 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2012-03-24 02:51:56 UTC
Created attachment 58962 [details]
Screenshot of the problem

Open the Customize -> Menus tab (Calc, Writer, Impress ). Select some menu entries under Entries, and the Description of that menu item at the bottom of the window will appear untranslated. 
The attached screenshot is Hungarian, but this was originally found by an Italian user, so it is likely an i18n problem. 
Downstream bug:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/957589
Comment 1 Andras Timar 2012-03-24 08:37:47 UTC
You did not have localized help package installed. These strings come from the help.
Comment 2 Björn Michaelsen 2012-04-18 10:54:09 UTC
I see the same issue here -- localized help is installed, but does not get picked up by LibreOffice. See also:

 https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/984942

any hints on what might cause this?
Comment 3 Björn Michaelsen 2012-04-18 12:10:17 UTC
Confirming on Debian Sid with libreoffice-1:3.5.2-4+b1
Comment 4 Gabor Kelemen 2012-04-18 12:43:33 UTC
I have found that simply removing the libreoffice-help-en-us package solves this problem.
Comment 5 Björn Michaelsen 2012-04-18 15:52:05 UTC
as per https://bugs.launchpad.net/ubuntu-translations/+bug/984942 this also affects the help itself.
Comment 6 Mihkel Tõnnov 2012-06-01 13:33:37 UTC
NOT confirmed on Debian Lenny, LibreOffice 3.5.4 (packages from libreoffice.org). Both en-US and et help packages are installed, but when UI language is set to Estonian, then help is also in Estonian (as far as it's translated, that is).

I don't remember seeing such a bug in earlier 3.5.x releases either, so perhaps it's a bug in the packages provided by Debian/Ubuntu (i.e. NOTOURBUG)?
Comment 7 Björn Michaelsen 2013-10-30 00:16:25 UTC
Not reproducible with LibreOffice 4.1 on Ubuntu 13.10 => WORKSFORME