Bug 47810 - EDITING: Inserting comment in a slide freezes mint 9
Summary: EDITING: Inserting comment in a slide freezes mint 9
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 10:47 UTC by maximo.fraga
Modified: 2012-08-22 08:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maximo.fraga 2012-03-24 10:47:18 UTC
Running LibreOffice 3.5.1 Impress in Linux Mint 9 (Gnome, LTS), when trying to add a comment to a slide, the laptop freezes and usually I must press shutdown button to restart the system. So I'm back to LibreOffice 3.4.6.
No such problem with LibreOffice 3.5.1 Impress in Linux Mint Debian Edition.
Thanks
Comment 1 Petr Mladek 2012-03-27 09:39:26 UTC
What do you exactly mean by adding a comment? Do you mean a sentence in the "Notes" tab? It works here.

Also, do it happen with a particular or any presentation?
Comment 2 maximo.fraga 2012-03-27 10:08:59 UTC
Thank you very mcuh for your attention.

What I mean is "Insert" (in "File, Edit, View, Insert..." bar), and the option is "Comment Ctrl+Alt+C". "Notes" tab works OK also in my system. However, I've tried this morning on a fresh install of Linux Mint 9 in a different PC (not my laptop) and it worked; not only that worked, but also bullets on/off in text by clicking the icon in upper margin (that did not work in my laptop). 

It happens with any kind of presentation, even a new ("empty") one.

In the "fresh" system, I simply removed openoffice and installed normally libreoffice 3.5. The only difference in that process with my laptop is that, previous to libreoffice 3.5, I had installed libreoffice 3.3 and 3.4 in laptop (obviously, other differences are the number and type of applications installed in every device and differences in hardware). Any suggestion about any dependence that could be lost or malfunctioning?

Thanks again
Comment 3 Petr Mladek 2012-03-29 03:52:05 UTC
The questions is why your entire system freezes during the operation.

One possibility is that LO gets into a cycle and eats the whole CPU or memory. You could try to run the command "top" in extra terminal and see what processes are active during the problematic operation and how it looks with memory.

Another possibility is that you X-server goes mad. I am not sure ho to debug this and add Lubos into CC.


Anyway, it seems that the problems is somehow specific to your system => it can't block the release => lowering the severity a bit.
Comment 4 maximo.fraga 2012-03-29 10:19:10 UTC
I was trying your suggestion about "top" in terminal. However, the GUI freezes and I can't see the change in "top" about the "soffice.bin" process. Curiously, the mouse cursor moves without problem but any click is unsuccessful. I've tried Ctrl+Alt+t to open a new terminal, but there was no response.

Then, I've opened a virtual console by Ctrl+Alt+F1 to run "top", but I didn't find any other process with my username than the "top" command (the rest were root processes). So I made pgrep soffice to find the PID number and killed the process. Then I could return to a responsive GUI.

I don't understand what you've said about "...not sure ho to debug
this and add Lubos into CC": what are "Lubos" and "CC"? Should I reinstall my X-server?

Thanks again
Comment 5 Petr Mladek 2012-03-30 09:32:24 UTC
Hmm, it looks like it somehow block events for your desktop. I would like to hear opinon from Lubos how to move forward.

Lubos is l.lunak@suse.cz. You might see him in the CC list in the top right corner of this bugzilla page.
Comment 6 maximo.fraga 2012-04-03 10:03:17 UTC
New information: 
I've tried LibreOffice 3.5 in virtual machines (virtualbox) into my laptop. Virtual Mint 9, same failure; virtual Mint 12, works OK.
Hope this can be a clue.
Thanks.
Comment 7 maximo.fraga 2012-04-07 03:03:38 UTC
Uninstalling LibreOffice 3.5.1 and installing the new version 3.5.2, the problem persists.
Comment 8 Luboš Luňák 2012-04-17 05:02:39 UTC
If Mint 9 has the problem and Mint 12 does not, then it looks likely that the problem is not in LibreOffice.
Comment 9 Julien Nabet 2012-08-15 21:37:09 UTC
Maximo: I don't know if you still have the problem with 3.5.5 (last LO 3.5.X version) but as Lubos said if it works with Linux Mint 12, it seems not our bug
Comment 10 maximo.fraga 2012-08-22 08:30:45 UTC
Thank you for all your comments. I upgraded to Mint 12 and everything works fine.