Bug 47828 - document shows error sizing of existing grouped drawing elements
Summary: document shows error sizing of existing grouped drawing elements
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 19:34 UTC by David Mawdsley
Modified: 2012-04-27 10:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample diagram in LibreOffice calc 'testconfig.ods' -- displays the incorrect sizing (19.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-24 19:34 UTC, David Mawdsley
Details
Notes inside screenshot (133.25 KB, image/png)
2012-03-26 04:58 UTC, David Mawdsley
Details
2nd of 4 screenshots. Notes inside (144.23 KB, image/png)
2012-03-26 05:00 UTC, David Mawdsley
Details
Figure 3 of 4 screenshots. Notes inside figure. (150.53 KB, image/png)
2012-03-26 05:01 UTC, David Mawdsley
Details
Figure 4 of 4 screenshots. Notes inside figure. (143.88 KB, image/png)
2012-03-26 05:05 UTC, David Mawdsley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Mawdsley 2012-03-24 19:34:41 UTC
Created attachment 58992 [details]
Sample diagram in LibreOffice calc 'testconfig.ods' -- displays the incorrect sizing

I have drawings made for a single cell in the spreadsheet calc with the drawing tools of calc.  When the page is loaded at a different time, parts of my drawings with grouped items are imaged much larger than normal.  I usually resize them and they're okay until I reload the page later.  My work-around is to ungroup the items though I prefer not to as they tend to have many parts.
Comment 1 Rainer Bielefeld Retired 2012-03-25 01:21:50 UTC
@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a source document without the problem
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected (not "Looks ugly")
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- Whether you see it as a FILEOPEN problem (document shown correctly with
     other LibO or OOo or whatever else software) or a FILESAVE problem 
     (document looks different after reopen with all other software)
  -- Any software with what that problem does not appear
  -- everything else crossing your mind after you read linked texts

Even  if you can not provide all demanded information, every little new information might bring the breakthrough.

Please submit reports with status UNCONFIRMED!

May be you can test <https://www.libreoffice.org/get-help/bug/> for submitting bug reports?
Comment 2 Rainer Bielefeld Retired 2012-03-25 08:08:31 UTC
@Urmas:
Please contribute requested information before or when you change Status from NEEDINFO to NEW
Comment 3 Urmas 2012-03-25 13:43:44 UTC
@Rainer: I can this bug clearly. If you are too lazy to open the attached document, what are you doing at QA?
Comment 4 Markus Mohrhard 2012-03-25 20:24:00 UTC
I'm one of the potentail devs who would fix this bug but as long as you are not helping by providing some more details it is impossible for me. So please follow the steps Rainer mentioned to make it possible to understand this bug report.
Comment 5 David Mawdsley 2012-03-26 04:58:45 UTC
Created attachment 59059 [details]
Notes inside screenshot

First of 4 screenshots with details inside each.

Figure 1 -- Original
Comment 6 David Mawdsley 2012-03-26 05:00:09 UTC
Created attachment 59060 [details]
2nd of 4 screenshots.  Notes inside

Figure 2 -- after resizing and moving to proper places of grouped items
Comment 7 David Mawdsley 2012-03-26 05:01:29 UTC
Created attachment 59061 [details]
Figure 3 of 4 screenshots.  Notes inside figure.

Figure 3 -- Reopened document.
Comment 8 David Mawdsley 2012-03-26 05:05:39 UTC
Created attachment 59062 [details]
Figure 4 of 4 screenshots.  Notes inside figure.

Figure 4 shows 2 of the ungrouped icons okay. but a grouped icon incorrect again.

I've supplied as best I can what's happening.  Hopefully you can fix this.  I've given up on the grouping for now.  But this is bad news for me as many of my diagrams. (over 100 in my business have complicated groupings that I prefer not to disturb.)

The groupings were okay when I used OpenOffice (version I can't remember.)
Comment 9 Rainer Bielefeld Retired 2012-04-27 05:02:51 UTC
I see the messed up result in reporter's sample document with all LibO versions back until "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit)" and OOo 3.3.3

I was not able to reproduce the problem with some few grouped objects pasted from DRAW

@David Mawdsley:
Do you know any OOo or LibO version showing that drawing correct?
I can't get a better result by ungrouping (checked 3.3.3, 3.5.3). What's the trick?
Is there any way to reproduce that problem with very few elements from the scratch?
Comment 10 David Mawdsley 2012-04-27 10:02:47 UTC
My Bug 47828 is probably a non-issue for LibreOffice!!  I tried to create the situation using a new document--not using an old document.  I was NOT able to reproduce the problem from scratch either.  So I'd like to consider the issue
resolved.

What I think happened was a conflict between when many of the original documents were created using Microsoft Office (Excel) 2003 on a Windows ME or XP years ago and my present setup.  The graphics shapes used then may have been in conflict with the present LibreOffice.  Those old diagrams were then migrated to Ubuntu 8.04 or later with OpenOffice and the Windows computers abandoned.  

On my present computer I'm using Ubuntu 10.04 with LibreOffice 3.5.2.2 with the same early documents.  It has no problems with diagrams made in newly created documents, but it has trouble with the older ones that seem to have some
incompatibilities.  I'll just deal with those older documents as they
come along.

I didn't see this issue when using OpenOffice (3.2.0) however.
Comment 11 Rainer Bielefeld Retired 2012-04-27 10:24:25 UTC
@David Mawdsley:
Thank you for your additional research. Please feel free to reopen this Bug if you find a way how to reproduce it from the scratch or other evidence that we have a LibO bug.