Bug 47917 - Impress crashes when closing in background
Summary: Impress crashes when closing in background
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
3.5.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2012-03-26 10:43 UTC by Martin
Modified: 2016-02-23 08:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:

gdb log (17.62 KB, application/octet-stream)
2012-03-26 10:43 UTC, Martin
crash report when putting LO in background and close it using right click -> stop in Mac OSX Dock (56.38 KB, text/rtf)
2012-12-14 17:10 UTC, Jorendc

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2012-03-26 10:43:03 UTC
Created attachment 59082 [details]
gdb log

Problem description: Almost everytime I close an odp file discarding changes Impress crashes (ppt files crash a little less). It also crashes at random intervals, mostly when editing it Outline view mode.

Steps to reproduce:
1. Open an odp file
2. Modify it
3. Close Impress and choose to discard changes

Current behavior: About 3/4 times it crashes.

Platform (if different from the browser): ArchLinux x86_64 without testing repo, KDE 4.8.1, Nvidia proprietary driver, kernel linux-ck 3.2.13
Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) konqueror/4.8.1 Safari/534.34

Long Description:
Impress crashes here at random intervals since maybe 1.5 or 2 years, at the point I'm getting used to it. Most tend to occur when working in Outline view. However, since version 3.5.0 it crashes almost always when closing the program (and also keeps crashing at random intervals, as usual).

The same happens no matter if:
- Extensions are or aren't installed
- Java is or isn't available (had jdk7-openjdk installed and then uninstalled it)
- Desktop integration is or isn't available (libreoffice-gnome, libreoffice-kde4 or none at all)
- Files are opened from dolphin or commandline with soffice
- I delete .config/libreoffice/
- Closing the whole program or just the opened file

I have almost no custom configuration in Libreoffice, I even tried completely uninstalling and reinstalling it (without keeping a single file in /usr/bin/libreoffice).

This is the message it gives when crashing from command line:
$ libreoffice --impress
Warning: failed to read path from javaldx
LibreOffice(13129) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf! 
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x5a01f93

I tried to debug it with gdb, but this way it doesn't crash, but freezes sometimes. Once it gave a segmentation fault, but no log at all. I attach a log I was able to create, but I think it gives no important information since the symptoms were different when I did it (it froze, and I had to kill the process).
Comment 1 Julien Nabet 2012-04-04 14:05:13 UTC
I did a research with this : "KSambaSharePrivate::findSmbConf: KSambaShare"
It seems a kde bug according to this thread :

I found other links about this : https://bugs.archlinux.org/task/28244

Some people resolved their problem containing this error by disabling Nepomuk (see http://chakra-project.org/bbs/viewtopic.php?id=6112)

I don't think a problem of smb.conf can't be caused by LO. (but perhaps I'm wrong)

Could you check smb.conf config and search on arch/kde forums ?
Comment 2 Martin 2012-04-07 19:52:47 UTC
First of all, thanks a lot for the answer.

I don't think samba has anything to do here, I don't even have it installed (nor have a smb.conf file). However, I tried installing and running it and got this when crashing after running from terminal:

[martin@cerdo ~]$ libreoffice --impress
warning: line 6172: incompatible stripping characters and condition
warning: line 6184: incompatible stripping characters and condition
warning: line 6432: incompatible stripping characters and condition
warning: line 6444: incompatible stripping characters and condition
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x5c04104
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x5c0020a
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x5c0020a

I also disabled Nepomuk as you suggested and this did, in fact, reduce the number of crashes. Now it happens 1/4 or 1/5 times.
Comment 3 Julien Nabet 2012-10-27 11:13:03 UTC
Martin: could you give a try to a newer LO version (3.5.7 or 3.6.2) after having renamed your LO profile (see http://wiki.documentfoundation.org/UserProfile)?
Comment 4 Jorendc 2012-12-14 17:09:34 UTC
I can reproduce when I add one more step between step 2 and 3...

I tested it with Mac OS X 10.8.2 (my other system specifications below)

1. Open an odp file
2. Modify it
!! put LibreOffice in the background by selecting another application in the 'Dock' (-> Mac OS X)
3. Close Impress BY RIGHT CLICKING the application in the dock (right click -> stop). Discard changes

This results in a crash. There is NO crash when the LibreOffice application is in the front.

See crash report attachment

system specifications: LibreOffice 4.0 Versie (Bouw-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37;
with Dutch Language pack; Mac OS X 10.8.2;
Comment 5 Jorendc 2012-12-14 17:10:47 UTC
Created attachment 71513 [details]
crash report when putting LO in background and close it using right click -> stop in Mac OSX Dock
Comment 6 tommy27 2013-09-20 11:27:04 UTC
Hi, is this "background crash" Impress specific or does it happens with Writer, Calc and Draw as well?
Comment 7 Joel Madero 2014-11-06 22:35:03 UTC
Looks like this is confirmed with a log so moving to NEW. If it's no longer a problem please set to RESOLVED -> WORKSFORME

Comment 8 Julien Nabet 2015-04-22 20:31:12 UTC
Any update with a recent LO version, 4.4.2 or at least 4.3.6? (if needed with a brand new LibreOffice profile)
Comment 9 QA Administrators 2015-12-27 20:31:21 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team
Comment 10 Timur 2016-02-23 08:01:51 UTC
No response.