Download it now!
Bug 48239 - FILEOPEN particular .xls with VBA segfaults when confirm all Syntax Errors
Summary: FILEOPEN particular .xls with VBA segfaults when confirm all Syntax Errors
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2012-04-03 04:24 UTC by p0p0
Modified: 2015-10-18 10:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
file with critical errors (70.00 KB, application/vnd.ms-excel)
2012-04-03 04:24 UTC, p0p0
Details
typescript with backtrace (29.50 KB, text/plain)
2013-12-29 20:34 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description p0p0 2012-04-03 04:24:47 UTC
Created attachment 59416 [details]
file with critical errors

Hi !


I have critical errors running some *. xls (with macro that I made) under Windows 64 (but not under Windows 7 32). The problem is not here with microsoft office.
Comment 1 Rainer Bielefeld Retired 2012-04-08 09:44:17 UTC
This is not a valid bug report.

I can confirm problems  with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit). Opening the document and allowing Macros I get lots of Basic error messages "Syntax Error. Unexpected Symbol ..." what I can confirm one by one clicking OK, but finally LibO will crash. Same with 3.4.5, .3.3., 
Some 3.5 WIN XP 32 (VirtualBox) and 3.4.4 Ubuntu (VirtualBox) 

I limit this bug to the crash problem.

@reporter:
Thank you for your report – unfortunately important information is missing. If you want to reopen additional bugs concerning the syntax error please contribute useful information. All th Bugs here are concerning problems ;-)
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS (Version (with Build ID if it's not a public release), 
     Distribution, Language)
  -- concerning your LibO version and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts

Even  if you can not provide all demanded information, every little new information might bring the breakthrough.

May be you can test <https://www.libreoffice.org/get-help/bug/> for submitting bug reports?
Comment 2 Teo91 2013-09-29 14:14:24 UTC
Too poor informations, not a valid bug report.
Comment 3 Terrence Enger 2013-12-29 20:34:50 UTC
Created attachment 91302 [details]
typescript with backtrace

Some pointers into the typescript:
   3: run-time messages from LibreOffice
  61: gdb backtrace from the core file with symbols

I am setting bug status NEW because of the crash.  I have no opinion
about whether LibreOffice should be able to load the macros; but if
it must fail, it should fail politely and informatively and without
taking all of LibreOffice with it.
Comment 4 Terrence Enger 2013-12-29 21:17:59 UTC
I should have said:

The backtrace is from master commit 480c7c2, fetched 2012-12-27 02:33
UTC, configured as:
    --enable-option-checking=fatal
    --enable-dbgutil
    --enable-crashdump
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
built and running on debian-wheezy 64-bit.

Setting importance back to normal because I am interested in this only
as an open item in bugzilla.  Anybody who encounters the problem in
actual use of LibreOffice is welcome to bump the importance up
again.
Comment 5 QA Administrators 2015-04-19 03:22:54 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 6 Terrence Enger 2015-04-22 16:41:45 UTC
I no longer see the segfault, but the sequence of msgbox's reporting
the BASIC syntax error seems to be unending.  This happens in both a
recent build of master on Linux and 4.4.2.2 running on Windows Vista.

I shall leave it for p0p0 to change the bug summary if he sees the
same changed behaviour.
Comment 7 Julien Nabet 2015-10-18 10:56:08 UTC
About infinite loop of error messages, there are some other bugtrackers (like tdf#77722)
So let's put this one to WFM.