Bug 48263 - Writer freezes when I begin to type after opening program on MacOS X when Sophos antivirus active
Summary: Writer freezes when I begin to type after opening program on MacOS X when Sop...
Status: CLOSED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-03 11:24 UTC by Ken Blowers
Modified: 2012-09-24 08:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Blowers 2012-04-03 11:24:49 UTC
Problem description: 

Steps to reproduce:
1. Open Writer blank text document
2. Begin to type characters
3. Observe spinning beach ball (hanging for long time)

Current behaviour: The cursor hangs and I get the spinning beach ball for a long time (up to 2 or 3 minutes)

Expected behaviour: I should be able to commence typing immediately without hanging or delay

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6.8; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Ken Blowers 2012-04-22 10:42:40 UTC
The computer that Libreoffice is installed on is a Macbook Pro 13 inch early 2011 with a i5 2.3Ghz processor and 8GB or RAM.

I am also running Sophos Antivirus software on this computer. I am also running iWork 9 from Apple.

I deleted the plist files associated with Libreoffice, then un-installed Libreoffice before re-installing it again. This did not fix the problem.
Comment 2 Ken Blowers 2012-04-22 11:03:14 UTC
I have discovered that turning off the Sophos Antivirus scanner before opening Libreoffice Writer fixes the problem.

If I re-enable the Sophos Scanner, then restart the computer, then open Libreoffice Writer again the problem re-appears.

The computer has all of the latest updates for all software installed including the latest Apple updates, Sophos Antivirus and Java.
Comment 3 Ken Blowers 2012-04-22 21:09:09 UTC
I will report this issue to Sophos.

Does anybody know what Libreoffice file(s) Sophos Antivirus could be taking so long to scan and clear ?
Comment 4 Roman Eisele 2012-08-23 13:05:21 UTC
Hello Ken Blowers,
thank you very much for your bug report, and also for all the investigation you have done on this issue yourself!


(In reply to comment #2)
> I have discovered that turning off the Sophos Antivirus scanner before opening
> Libreoffice Writer fixes the problem.

Would you agree to say that this is rather a problem in/with Sophos Antivirus? Then we could mark this bug report as RESOLVED/NOTOURBUG ...


(In reply to comment #3)
> Does anybody know what Libreoffice file(s) Sophos Antivirus could be taking so
> long to scan and clear ?

A good question. I can’t answer it, because I don’t use Sophos Antivirus (and can’t install it due to technical reasons). Maybe someone else can help ...
Comment 5 Alex Thurgood 2012-08-23 13:47:54 UTC
Does Sophos Antivirus scan network connections ? If so, then one of the reasons for the lag could be that LO initiates a network connection on startup to see if any updates are available, and that this network connection has first to be validated by Sophos before allowing the soffice process to continue.

If you use just the normal Mac firewall provided by the OS, it actually will ask you the question whether or not to allow incoming connections to the soffice process (soemtimes it only appears for a very brief moment in a window, before disappearing).


Alex
Comment 6 Roman Eisele 2012-09-20 09:15:26 UTC
Sophos even recognizes it’s own updater as malware:

http://community.sophos.com/t5/Sophos-Endpoint-Protection/Is-any-one-else-seing-this-alert-Shh-Updater-B-False-positives/td-p/29723/page/26

... please draw your own conclusions about software quality from this ;-)
Comment 7 Ken Blowers 2012-09-23 00:09:34 UTC
By default, the Sophos "on access scanning" option is not set to scan within archives and compressed files or network volumes. However, I had manually checked the option to scan within archives and compressed files. This is what triggered the problem.

I have since unchecked that option, and now the problem doesn't occur any more.

As far as false positives are concerned, many of the available anti-virus products that actually catch most viruses, and some that don't, have unfortunately produced false positives in the past.(In reply to comment #6)
> Sophos even recognizes it’s own updater as malware:
> 
> http://community.sophos.com/t5/Sophos-Endpoint-Protection/Is-any-one-else-seing-this-alert-Shh-Updater-B-False-positives/td-p/29723/page/26
> 
> ... please draw your own conclusions about software quality from this ;-)

========================================

By default, the Sophos "on access scanning" option is not set to scan within archives and compressed files or network volumes. However, I had manually checked the option to scan within archives and compressed files. This is what triggered the problem.

I have since unchecked that option, and now the problem doesn't occur any more. I would however, still like the product to scan within any compressed files that I might download from the net just in case they are infected. That was the reason that I had check the option to begin with.

As far as false positives are concerned, many of the available anti-virus products that actually catch most viruses, and some that don't, have unfortunately produced false positives in the past.
Comment 8 Roman Eisele 2012-09-24 06:20:59 UTC
(In reply to comment #7)
> By default, the Sophos "on access scanning" option is not set to scan within
> archives and compressed files or network volumes. However, I had manually
> checked the option to scan within archives and compressed files. This is
> what triggered the problem.

Thank you very much for figuring out this! So now we know what’s going on.

What do you mean with status “Assigned”? Assigned to whom? ;-) Normally this status is used when a bug has been approved and assigned (sic) to a developer who is now responsible to fix it. So, if you mean “this is not a bug” or “this is not LibreOffice’ bug”, you may want to use status RESOLVED+NOTABUG or RESOLVED+NOTOURBUG instead.

(In parenthesis:
> As far as false positives are concerned, many of the available anti-virus
> products that actually catch most viruses, and some that don't, have
> unfortunately produced false positives in the past.

I know -- my point was that Sophos had managed to catch *itself*, which is IMHO much worse than the ordinary (and probably unavoidable) false positives. But you may just ignore such amusements of an overworked bugwrangler.
)
Comment 9 Alex Thurgood 2012-09-24 08:23:34 UTC
Setting to NOTOURBUG and closing. 

Alex