Bug Hunting Session
Bug 48296 - Copy and paste text or cells from LibreOffice to any other office takes about 5 seconds
Summary: Copy and paste text or cells from LibreOffice to any other office takes about...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-04 07:37 UTC by andreas.kirmair
Modified: 2015-06-20 12:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas.kirmair 2012-04-04 07:37:08 UTC
Hi there,

We have following problem on about half our computers (about 100):
If I copy a cell from calc or text from writer, it takes about 5 seconds
before it goes into the clipboard and so i can paste it in other applications.

We are running winXP sp3 and LibO 3.5.1
Comment 1 Lukas Tribus 2012-07-08 11:57:11 UTC
Reproduced in LO 3.5.4.2 under Windows Vista x64 SP2. Its very annoying, I wonder why there are just 2 people reporting it.

Problem description: 

Steps to reproduce:
1. Copy text from calc or writer
2. alt-tab to another programm like a browser or notepad
3. ctrl - v the clipboard: doesn't work right after the ctrl - c; only after about 5 seconds, ctrl - v works (seems that between ctrl - c and when it works, the clipboard contains just an empty string)

Current behavior:
LO needs about 5 seconds the copy content into clipboard.

Expected behavior:
LO should copy content to clipboard without any delay.


Intra-LO clipboard is not affected, only clipboard between LO and non-LO applications (like windows notepad) are affected.

OS is Windows Vista x64 SP2 here.
Comment 2 Lukas Tribus 2012-07-08 23:08:31 UTC
In my case, the issue seems resolved when closing the "Nokia Suite" Application in tray.

Andreas, can you please check whether the affected computers have the "Nokia Suite" installed, and if you can still reproduce it after closing the Nokia Suite tray application?


Here is how I can reproduce the issue exactly:
1. LO should be closed (application + quickstarter)
2. Nokia Suite (latest v3.4.49) tray application should be started ("C:\Program Files (x86)\Nokia\Nokia Suite\NokiaSuite.exe -tray")
3. open LO, try to use copy and paste externally (you should be able to reproduce the issue)
4. Close Nokia Suite: no more issues
5. reopen Nokia Suite tray: still no issues


Seems like this issue can be reproduced only when Nokia Suite in tray mode is started before LibreOffice.
Comment 3 Lukas Tribus 2012-08-15 16:31:52 UTC
It doesn't seem to be specific to the "Nokia Suite". Exactly the same issue can be reproduced with a VNC client.

1. close all LO instances and process
2. open a VNC session with UltraVNC Win32 Viewer 1.0.4
3. open LO and copy content from LibreOffice Calc cells into clipboard
4. alt-tab to firefox, paste it. You will see the 5 second delay.

The important thing for reproduction is to execute VNC or Nokia Suite before starting LO.

Reproduced in 3.6.0.4 release.
Comment 4 Björn Michaelsen 2014-01-17 00:43:42 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 5 Joel Madero 2015-05-02 15:41:16 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 6 Buovjaga 2015-06-20 12:31:03 UTC
Don't know why VNC or Nokia suite causing issues to the operating system would be LibreOffice's problem.
I can't repro the delay, can paste instantly after quickly alt-tabbing to browser after copying.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)