Bug 48321 - some menus placed outside the window or right aligned in non full-screen mode and with two displays and the office on the one at right
Summary: some menus placed outside the window or right aligned in non full-screen mode...
Status: RESOLVED DUPLICATE of bug 46469
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-04-05 01:51 UTC by Cor Nouws
Modified: 2012-06-20 01:58 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (66.14 KB, image/png)
2012-04-05 01:52 UTC, Cor Nouws
Details
woops, now the menu is gone somewhere else :-) (76.80 KB, image/png)
2012-04-05 05:19 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-04-05 01:51:17 UTC
Start LibreOffice, not full screen
start Menu File
  > the menu is placed partly left of the window

All the menus are right aligned

LOdev 36daily120404 3.6.0alpha0+ 
Build ID: 290654c-042f74a-6299bf6-879ce36-186d9e

I'll attach a screenshot
Comment 1 Cor Nouws 2012-04-05 01:52:45 UTC
Created attachment 59510 [details]
screen shot
Comment 2 Cor Nouws 2012-04-05 02:14:12 UTC
was fine in daily from apr. week ago (2012-03-26):

LOdev 36daily120326 3.6.0alpha0+ 
Build ID: a04fee7-4d74905-6299bf6-879ce36-4c023a

and it's so ... :-) > critial
Comment 3 Cor Nouws 2012-04-05 02:18:42 UTC
hmm funny, only visible in start screen, so without a document open
Comment 4 Cor Nouws 2012-04-05 05:19:41 UTC
Created attachment 59518 [details]
woops, now the menu is gone somewhere else :-)
Comment 5 Cor Nouws 2012-04-05 10:57:58 UTC
and now with no extra display attached, I do not see the wrong behaviour ...
Comment 6 Cor Nouws 2012-04-18 03:52:44 UTC
this problem does not show up again :-)
Comment 7 Cor Nouws 2012-04-18 03:53:09 UTC
thus close
Comment 8 Steve 2012-05-24 08:30:27 UTC
I also have this problem in 3.5.3.2 release, English UK, so re-opening.

And it does occur with documents open and in multiple windows. It is very annoying and did not occur with previous versions.

As hinted by previous comments.

I have a dual monitor set up.

When the document window is in the left monitor, the menus are left aligned as expected. If the document window is moved to the right monitor the menus are right aligned and so the file menu is outside of the window area.

But perhaps I should start an new bug report ?
Comment 9 Cor Nouws 2012-05-24 09:28:41 UTC
Hi Steve,

(In reply to comment #8)
> I also have this problem in 3.5.3.2 release, English UK, so re-opening.
> [...]
> But perhaps I should start an new bug report ?

hé, interesting...
I haven't seen it after the initial problem - maybe I shoudld have restarted the whole laptop befor writing the bug in the first place.

> When the document window is in the left monitor, the menus are left aligned 
> as expected. If the document window is moved to the right monitor the menus 
> are right aligned and so the file menu is outside of the window area.

When I had the problem, that was unrelated.
Can reliably you reproduce the problem?
Have you been able maybe to try with a daily build too?

thanks
Comment 10 Cor Nouws 2012-05-25 03:13:01 UTC
hmm, now I stumble over the bug too.
Seems indeed related to draging a window to the other monitor. Something I obviously don't do that often.
So thanks Steve, that you gave the insight in when it bugs.
I'm going to look in which version it started..
Comment 11 Cor Nouws 2012-05-25 03:25:04 UTC
the first version where I see this is 3.5.0rc1
Build ID: b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87


updating the summary, so that it exaclty tells what the problem is
Comment 12 Cor Nouws 2012-05-25 03:26:07 UTC
by the way, I'm not on 64 bits, so I think the platform should be 'all'
Comment 13 Ruslan Kabatsayev 2012-06-15 05:42:52 UTC
Looks like a dup of bug 48168
Comment 14 Ruslan Kabatsayev 2012-06-15 16:45:02 UTC
Someone please check if this patch fixes this bug: https://bugs.freedesktop.org/attachment.cgi?id=63092&action=edit
Comment 15 Steve 2012-06-16 09:04:33 UTC
I am in production set up. How do I test the patch ?
Comment 16 Ruslan Kabatsayev 2012-06-17 12:44:12 UTC
(In reply to comment #15)
> I am in production set up. How do I test the patch ?

You'll have to build libreoffice from source, having applied this patch (and install somewhere like /opt to prevent breakage of currently installed version). Depending on distro, you might have an easier way to build than setting the build environment manually.
Comment 17 Ruslan Kabatsayev 2012-06-19 02:40:44 UTC
The patch has been pushed to 3.6 and 3.5.5 . You can now try libreoffice nightly builds to check it out.
Comment 18 David Tardon 2012-06-20 01:58:49 UTC

*** This bug has been marked as a duplicate of bug 46469 ***