Bug 48329 - Crash when adding borders, in Writer and Calc
Summary: Crash when adding borders, in Writer and Calc
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Mac OS X (All)
: medium major
Assignee: mikebgx
URL:
Whiteboard:
Keywords:
: 46692 50612 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-05 04:04 UTC by mikebgx
Modified: 2012-08-20 20:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
stacktrace (78.04 KB, text/plain)
2012-04-05 04:04 UTC, mikebgx
Details
help_poster.doc (11.50 KB, application/msword)
2012-04-19 10:07 UTC, mikebgx
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikebgx 2012-04-05 04:04:10 UTC
Created attachment 59515 [details]
stacktrace

Using v3.5.1.2 on Mac (Intel)

Adding borders to a paragraph in Writer, or above 4 cells in a Calc sheet, causes LO to crash.


Contact me if you want the offending .doc (I can't attach 2 things here), help_poster.doc, simply go to end of it and add a "border below"

Stack trace is attached
Comment 1 Nino 2012-04-19 05:48:38 UTC
works in 3.5.2.2/Linux

@ mikebgx :
Please try 3.5.2, maybe it's fixed already. If not, please add addtional info, e.g. the document. We need to reproduce the bug reliably.
Comment 2 Nino 2012-04-19 09:35:20 UTC
(removing libo-bugs@fdo from CC)
Comment 3 Nino 2012-04-19 09:36:07 UTC
Created attachment 60329 [details]
help_poster.doc

(removing libo-bugs@fdo from CC again, sorry)
Comment 4 mikebgx 2012-04-19 10:07:16 UTC
Thanks but still bad on v 3.5.2.2, with attached .doc

Best Regards

Mike Burton
Myco Systems Ltd
01753 893390
17 Criss Grove, Gerrards Cross, BUCKS, SL9 9HG
Registered in England No 1832705

NOTICE: If received in error, please destroy and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error.
Comment 5 Nino 2012-04-21 17:27:30 UTC
@Mike:
I tried with help_poster.doc and had no problem adding borders to any of the paragraphs. How did you add borders? Can you provide step by step instruction?
(Note: Please take care, all e-mails are archived publicly)
Comment 6 mikebgx 2012-04-23 02:40:23 UTC
Many thanks for your reply. Here are the step by step instructions to reproduce the bug:

File> Open...
Position cursor at bottom of document
Format> Paragraph> Borders
 click on the bottom line, so as to draw a line UNDER the paragraph
 press OK

In going through the above I found an even easier way to crash it:
Format> Paragraph> Borders
 click any line, then press CANCEL

As a software developer myself, this bug gives me a sinking feeling about dependencies on the other pieces of software that are involved. Having moved away from Java I hope you don't get the situation where every installation is a unique combination of software and hence virtually impossible to maintain, ala Windows / DLL hell.

I don't experience the above bug in either NeoOffice or OpenOffice by the way.
Interestingly, OpenOffice (v3.3.0) does have the strange formatting problem like LibreOffice, where bullet points show as space-invader characters.


Best Regards

Mike Burton
Myco Systems Ltd
01753 893390
17 Criss Grove, Gerrards Cross, BUCKS, SL9 9HG
Registered in England No 1832705

NOTICE: If received in error, please destroy and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error.




On 22 Apr 2012, at 01:27, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=48329
> 
> --- Comment #5 from Nino <nn.libo@kflog.org> 2012-04-21 17:27:30 PDT ---
> @Mike:
> I tried with help_poster.doc and had no problem adding borders to any of the
> paragraphs. How did you add borders? Can you provide step by step instruction?
> (Note: Please take care, all e-mails are archived publicly)
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are the assignee for the bug.
> You reported the bug.
Comment 7 Nino 2012-04-23 03:29:04 UTC
(In reply to comment #6)

> File> Open...
> Position cursor at bottom of document
> Format> Paragraph> Borders
>  click on the bottom line, so as to draw a line UNDER the paragraph
>  press OK

No problem with Linux x86 3.5.3.1
 
> In going through the above I found an even easier way to crash it:
> Format> Paragraph> Borders
>  click any line, then press CANCEL

No problem either.

So looks like Mac OSX specific bug? Other platforms should try to reproduce. Therefore, I'm changing back to status UNCONFIRMED + adding rbd to cc.

> Interestingly, OpenOffice (v3.3.0) does have the strange formatting problem
> like LibreOffice, where bullet points show as space-invader characters.

Please open a different bug for this. Thanks.
Comment 8 m.a.riosv 2012-04-23 05:05:55 UTC
No problem in attached doc win with  Win7x64 Ultimate, LibreOffice 3.5.3RC1
Comment 9 mikebgx 2012-04-24 08:36:05 UTC
> 
>> Interestingly, OpenOffice (v3.3.0) does have the strange formatting problem
>> like LibreOffice, where bullet points show as space-invader characters.
>> 
> Please open a different bug for this. Thanks.
I'm sure this has been reported already, just about everyone I know using LibreOffice mentions it

Best of luck with your efforts, and thanks for all your good work


Best Regards

Mike Burton
Myco Systems Ltd
01753 893390
17 Criss Grove, Gerrards Cross, BUCKS, SL9 9HG
Registered in England No 1832705

NOTICE: If received in error, please destroy and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error.




On 23 Apr 2012, at 11:29, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=48329
> 
> Nino <nn.libo@kflog.org> changed:
> 
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|NEEDINFO                    |UNCONFIRMED
>                 CC|                            |LibreOffice@bielefeldundbus
>                   |                            |s.de
>     Ever Confirmed|1                           |0
> 
> --- Comment #7 from Nino <nn.libo@kflog.org> 2012-04-23 03:29:04 PDT ---
> (In reply to comment #6)
> 
>> File> Open...
>> Position cursor at bottom of document
>> Format> Paragraph> Borders
>> click on the bottom line, so as to draw a line UNDER the paragraph
>> press OK
> 
> No problem with Linux x86 3.5.3.1
> 
>> In going through the above I found an even easier way to crash it:
>> Format> Paragraph> Borders
>> click any line, then press CANCEL
> 
> No problem either.
> 
> So looks like Mac OSX specific bug? Other platforms should try to reproduce.
> Therefore, I'm changing back to status UNCONFIRMED + adding rbd to cc.
> 
>> Interestingly, OpenOffice (v3.3.0) does have the strange formatting problem
>> like LibreOffice, where bullet points show as space-invader characters.
> 
> Please open a different bug for this. Thanks.
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are the assignee for the bug.
> You reported the bug.
Comment 10 Rainer Bielefeld Retired 2012-04-24 10:26:18 UTC
NOT [Reproducible] with "LibreOffice 3.5.3.1 (RC1) German UI/Locale [Build-ID: 21cb047-d7e6025-9ba54fc-b4a51a8-f42372b] on German WIN7 Home Premium (64bit) "

Might be related to / DUP of 
"Bug 47015 - EDITING: table border editing crash"
"Bug 47368 - Many crashes when accessibility enabled on MAC"?

@mikebgx
Can you please leave away address data, phrase of civility, ... . We try to keep this all short
Comment 11 Michael Stahl (CIB) 2012-05-22 02:00:51 UTC
*** Bug 46692 has been marked as a duplicate of this bug. ***
Comment 12 Roman Eisele 2012-05-23 03:46:56 UTC
NOT REPRODUCIBLE on MacOS X 10.6.8 German UI, Intel Mac, with LibreOffice 3.5.4.1, German langpack installed. If I open the sample file (help_poster.doc) and try (quoting comment #6):

> File> Open...
> Position cursor at bottom of document
> Format> Paragraph> Borders
>  click on the bottom line, so as to draw a line UNDER the paragraph
>  press OK

No crash, bottom line below the paragraph, as expected.

> In going through the above I found an even easier way to crash it:
> Format> Paragraph> Borders
>  click any line, then press CANCEL

No crash, bottom line below the paragraph, as expected.

(From comment #1:)
> Adding borders [...] or above 4 cells in a Calc sheet,
> causes LO to crash.

No crash again.

Hm ... looks like a complicated issue: even on MacOS the crash is not always reproducible.
Comment 13 Roman Eisele 2012-05-23 04:13:09 UTC
Also
NOT REPRODUCIBLE on MacOS X 10.6.8 German UI, Intel Mac, with LibreOffice 3.5.3.2, German langpack installed. Everything like stated in comment #12.

@mikebgx:
Maybe this bug was just fixed by the way in the LibreOffice 3.5.3.x development process. Could you please test if it is still reproducible for you with the current LibreOffice version (3.5.3.2, or 3.5.4rc1)? This would be very helpful. Thank you!
Comment 14 Roman Eisele 2012-05-29 01:13:33 UTC
(In reply to comment #13)
> @mikebgx:
> Maybe this bug was just fixed by the way in the LibreOffice 3.5.3.x development
> process. Could you please test if it is still reproducible for you with the
> current LibreOffice version (3.5.3.2, or 3.5.4rc1)? This would be very helpful.
> Thank you!

mikebgx replied to me (2012-05-28):
> It's "fixed" on Writer 3.5.3.2 well done guys!!

Therefore I close this bug report as RESOLVED/FIXED.
Comment 15 Roman Eisele 2012-05-29 02:54:15 UTC
Supplement:
Maybe I should mention, that mikebgx (the original reporter) wrote also to me (2012-05-28):
> Similar problem on Calc 3.5.3.2 still exists,
> should I file a new report or add to this one?

I have asked him to file a new report. Reason: If there is still a problem in Calc, it seems probable that this remaining problem is independend from the present (fixed) problem in Writer; therefore, a separate bug report seems recommendable.
Comment 16 Roman Eisele 2012-05-29 05:17:07 UTC
(Should be better RESOLVED/WORKSFORME, not /FIXED, sorry!)
Comment 17 Michael Stahl (CIB) 2012-08-20 20:48:41 UTC
*** Bug 50612 has been marked as a duplicate of this bug. ***