Download it now!
Bug 48423 - PostgreSQL-SDBC: newly inserted omitted values shown as zero
Summary: PostgreSQL-SDBC: newly inserted omitted values shown as zero
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-07 11:34 UTC by Luc MASSENAUX
Modified: 2018-07-17 12:18 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the date display issue (2.97 KB, image/png)
2012-04-07 11:34 UTC, Luc MASSENAUX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luc MASSENAUX 2012-04-07 11:34:18 UTC
Created attachment 59629 [details]
Screenshot of the date display issue

LibreOffice Base does not display date fields properly with the native driver included in LibreOffice 3.5.2.

Date fields are allways displayed as 01/01/1800 (DD/MM/YYYY). This issue not only happens with null values, but also when the date fields are actually set to a proper value.

Screenshot provided.
Comment 1 Jochen 2012-08-27 18:02:52 UTC
Hi Rainer,

do you understand, waht reporter means?
Comment 2 Alex Thurgood 2012-08-27 19:23:06 UTC
(In reply to comment #1)
> Hi Rainer,
> 
> do you understand, waht reporter means?

Pretty simple IMHO :
1) Create an ODB file which connects to a postgresql db via the native postgres connector now included in LO by default.

2) Load a table containing dates, or create one, and check the result displayed :
- in the table itself
- in a form (as the user has provided a snapshot in colour, I'm betting that this is a form display and not the Table view display).

3) Check to see whether problem exists.


4) Also check to see whether it is not a duplicate of some other database form display problems (I seem to recall that there is one already).


Alex
Comment 3 Alex Thurgood 2012-08-27 19:23:45 UTC
Looking at the screenshot again, it is definitely a form.

Alex
Comment 4 Alex Thurgood 2012-08-27 19:27:49 UTC
Adding link to fdo#36858 because I think that it is possibly the same underlying problem.


Alex
Comment 5 Lionel Elie Mamane 2013-04-17 01:29:57 UTC
I get this only for NULL dates
Comment 6 Lionel Elie Mamane 2013-04-17 02:04:49 UTC
Actually, I get that only on newly inserted rows, and only for the fields that were not filled in. For integer fields, I get "zero".
Comment 7 Simon Richter 2013-08-04 16:51:18 UTC
I've stumbled over something similar in a form:

I have two tables, "accounts" and "transactions", and a form showing both (with the latter being limited to the currently selected account, which is a foreign key in the transactions table.

When I insert a new account, it is inserted properly, but the account ID (which is set by Postgres from a sequence) is assumed to be 0. When I then attempt to insert a transaction for that account, the INSERT fails because 0 is not a valid account ID and so the foreign key constraint is not met.

Closing and reopening the form rereads the ID, and allows me to insert transactions.
Comment 8 Alex Thurgood 2015-01-03 17:39:33 UTC Comment hidden (no-value)
Comment 9 QA Administrators 2016-01-17 20:05:11 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2017-03-06 14:36:35 UTC Comment hidden (obsolete)
Comment 11 Julien Nabet 2018-07-03 07:30:08 UTC
Any update with 6.0.5 + the fact that tdf#36858 has been fixed?
Comment 12 Xisco Faulí 2018-07-04 10:57:16 UTC
(In reply to Julien Nabet from comment #11)
> Any update with 6.0.5 + the fact that tdf#36858 has been fixed?

Dear Luc MASSENAUX, Alex Thurgood,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
Comment 13 Alex Thurgood 2018-07-17 12:18:01 UTC
No repro for me with:

Version: 5.4.7.2
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
Threads CPU : 8; OS : Mac OS X 10.13.5; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group