Download it now!
Bug 48500 - Text in custom shape does not follow text anchor complete way.
Summary: Text in custom shape does not follow text anchor complete way.
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-10 04:50 UTC by Regina Henschel
Modified: 2017-03-06 17:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample shapes (13.00 KB, application/vnd.oasis.opendocument.graphics)
2012-04-10 04:50 UTC, Regina Henschel
Details
screenshot of the document (13.02 KB, image/png)
2012-04-10 10:41 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2012-04-10 04:50:22 UTC
Created attachment 59718 [details]
Sample shapes

Draw a custom shape.
Enter some text (press F2 if needed).
Format > Text. Set text anchor to top, left. Set border spacing to 0cm.
Notice that the position of the text is wrong.

Not all kind of shapes are effected. Faulty shapes are at least from category 'Basis Shapes':
triangles (drag corner to the left), trapezoid, parallelogram (drag corner to get rectangle), hexagon (drag to rectangle and compare with octagon), circle and circle-pie (inconsistent)
Comment 1 Rainer Bielefeld Retired 2012-04-10 10:22:36 UTC
NOT reproducible with reporter's sample and with parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 4495824-6299bf6-ec8645]" (tinderbox: Win-x86@6-fast pull time 2012-04-08 00:03:52). Also failed with own sample document.

@Regina
What OS and particular Build-ID / Pull Time did you use? Any Idea concerning a setting outside document that might be related?
Comment 2 Regina Henschel 2012-04-10 10:41:33 UTC
Created attachment 59740 [details]
screenshot of the document

I work on German WinXP 32bit.

LOdev 3.6.0alpha0+ 
Build ID: 5d2b0f2-6299bf6-879ce3
It is a debug build.

But I see the same error in LibreOffice 3.5.2.2 
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f
I see the same error in Apache OpenOffice and in OOo2.4.3. So I guess it has been there from the beginning of custom shapes.
Comment 3 Rainer Bielefeld Retired 2012-04-10 10:59:03 UTC
Also not reproducible with "LibreOffice 3.5 (forgot to look what Version exactly) German UI on German WIN XP Home 32Bit (VirtualBox)

Strange!
Comment 4 bfoman (inactive) 2012-08-31 12:13:10 UTC
Confirmed with:
LO 3.5.6.2 
Build ID: own W7 debug build
Windows 7 Professional SP1 64 bit

Confirmed with:
LO 3.6.1.2
Build ID: e29a214
Windows 7 Professional SP1 64 bit

LO position text in custom shape.odg looks like on attached screenshot.
Comment 5 Rainer Bielefeld Retired 2012-08-31 13:42:24 UTC
Today I tripped over this Bug again, and crazy enough, I can confirm it with all tested Versions, reporter#s sample and own Dawings:
[Reproducible] with Server Installation of "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit) 
[Reproducible] with "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit) 
Also 3.6.1.2,

Also LibO 3.3.3, AOOo 3.4, so inherited from OOo

@Radek:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 6 QA Administrators 2015-01-05 17:52:27 UTC Comment hidden (obsolete)
Comment 7 Regina Henschel 2015-01-05 23:30:45 UTC
The bug is still present. I've tested Version: 4.5.0.0.alpha0+
Build ID: 5b829710d65310c6082c2c65ec1239515e319a8e
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-02_06:39:26
Locale: de_DE
Comment 8 QA Administrators 2016-01-17 20:05:20 UTC Comment hidden (obsolete)
Comment 9 Regina Henschel 2016-01-17 21:35:39 UTC
The bug is still present. I have tested Version: 5.2.0.0.alpha0+
Build ID: e413549dc8b5669a806eeabc30c7d6f92723a882
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-28_23:26:49
Locale: de-DE (de_DE)
Comment 10 QA Administrators 2017-03-06 14:39:18 UTC Comment hidden (obsolete)
Comment 11 Regina Henschel 2017-03-06 17:45:12 UTC
The reason seems to be the different definitions of the draw:text-areas attribute of the enhanced geometry.