Bug 48539 - : Add ~/Templates in paths used by LibreOffice
Summary: : Add ~/Templates in paths used by LibreOffice
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86-64 (AMD64) Linux (All)
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-11 01:53 UTC by vulcain
Modified: 2013-02-24 11:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2012-04-11 01:53:32 UTC
Problem description: 

Steps to reproduce:
1. ....Downlaod Ubuntu 12.04 ß 2
2. ....Install on your computer
3. ....Open LibreOffice

In LibreOffice in Ubuntu 12.04, there are 2 paths for Templates:
- /usr/lib/libreoffice/program/../share/template/common
- ~/.config/libreoffice/3/user/template
We can know that if we go to Menu -> Option -> Tools -> LibreOffice -> Paths. Here, we have paths for image, my documents, templates, gallery, etc ...
But, in /home, we have a folder with name: Templates. If a clic right in Nautilus, we have contextuel menu. In this one, we can go to "Create a new document". If we have a document (a curriculum vitaæ for exemple) in ~/Template, we can found it in Clic right -> Create a new document -> curriculum vitæ.


Current behavior: missing ~/Templates in the path for template

Expected behavior:add ~/Templates in the path for template 

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

It's could be only an Ubuntu, i don't know if other Linux's distribution affected.
There are a bug in launchpad: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/973134
Comment 1 Urmas 2012-04-12 02:52:58 UTC
I don't think that is a good idea, as Templates folder is intended to documents of multiple types, as opposed to many different templates of the same type.
Comment 2 Joel Madero 2012-06-17 19:23:55 UTC
Can you explain a bit why the current method doesn't work where you can just add Templates from Tools->LibreOffice-> Paths? Are you saying that you want it set as default? I'm just a bit confused, going to mark as NEEDINFO. Once you add the info please mark it back to UNCONFIRMED and we'll check it out again
Comment 3 vulcain 2013-01-17 22:42:34 UTC
@  Urmas: I don't understand: A folder template it's for keep Templates, why not use it ??

@ Joel Madero: Yes, i want to add it by default because there are a Template's folder by default in /home