Bug 48647 - ugly hairline double border drawing
Summary: ugly hairline double border drawing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:3.6.0 target:3.5.4
Keywords: regression
Depends on:
Blocks: 44768
  Show dependency treegraph
 
Reported: 2012-04-13 06:00 UTC by Michael Stahl (CIB)
Modified: 2012-04-26 08:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
simple bugdoc (8.72 KB, application/vnd.oasis.opendocument.text)
2012-04-13 06:02 UTC, Michael Stahl (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2012-04-13 06:00:40 UTC
in the attachment in bug 42750 there is another problem:
the corners where the double borders meet look really ugly,
the lines cross and stick out over the other border.

this can easily be reproduced by creating a new table with
double line style in Writer.
Comment 1 Michael Stahl (CIB) 2012-04-13 06:02:53 UTC
Created attachment 59908 [details]
simple bugdoc

the effect is interesting:
the bug happens up to about 273% zoom level, but at 277% and higher
the borders are connected properly and look right.
Comment 2 Not Assigned 2012-04-18 13:19:56 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=49bd0e4e6bb0ed0671de72d84700ddcc49828f69

fdo#48647: drawinglayer: fix double hairline borders:
Comment 3 Michael Stahl (CIB) 2012-04-18 13:24:42 UTC
so this was actually quite easy, the hairline case was
not using the ClipRegion and simply clipping with the
right parameters seems to result in neat borders.

please note that because commit
2c91cb08d65cd35fa8ef6eaca3677aa82fb58cbe
changed the hairline predicates on master such that a
border in Writer is never considered a hairline
(because Writer borders are never thinner than 1 twip),
this bug cannot actually be observed in Writer on master now,
but it can be observed in Calc on master.
Comment 4 Not Assigned 2012-04-20 06:19:53 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=339a502e1f78388512cc8b9ba2117b674c770efc&g=libreoffice-3-5

fdo#48647: drawinglayer: fix double hairline borders:


It will be available in LibreOffice 3.5.4.