Bug 48715 - FILEOPEN EDITING Unable to edit text in textboxes from Word .doc
Summary: FILEOPEN EDITING Unable to edit text in textboxes from Word .doc
Status: RESOLVED DUPLICATE of bug 120761
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc
Depends on:
Blocks: DOC-Textbox
  Show dependency treegraph
 
Reported: 2012-04-14 18:30 UTC by Christopher M. Penalver
Modified: 2021-09-15 14:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test case (196.50 KB, application/msword)
2016-12-06 13:08 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2012-04-14 18:30:34 UTC
Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/897597

1) lsb_release -rd
Description:    Ubuntu precise (development branch)
Release:    12.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/897597/+attachment/2612177/+files/Test%20case.doc -O testcase.doc && lowriter -nologo testcase.doc

is when you double click the first textbox (Pzuorn) you can edit the text that is in the textbox.

4) What happens instead is it is not editable, and one writes new text over the old.
Comment 1 Teo91 2013-09-29 13:59:19 UTC
I can confirm this with LO 4.1.1. on Windows 7 SP1
Comment 2 QA Administrators 2015-04-01 14:40:38 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-04-22 11:56:16 UTC
Well the boxes are just floating on top of the text.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI
Comment 4 QA Administrators 2016-09-20 09:33:03 UTC Comment hidden (obsolete)
Comment 5 Telesto 2016-12-06 13:08:22 UTC
Created attachment 129347 [details]
Test case
Comment 6 Telesto 2016-12-06 13:12:34 UTC
Still reproducible
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 7 QA Administrators 2018-10-01 02:53:08 UTC Comment hidden (obsolete, spam)
Comment 8 Justin L 2020-04-24 08:00:40 UTC
repro 7.0+
Comment 9 Timur 2021-09-15 14:26:38 UTC
Resolved in 7.2.

commit 34d8655d9141e3699a9ab83e1e39a656ef9760e2
Date:   Sat Apr 10 18:16:40 2021 +0200
    source sha:a6e271621843f454d92bc2c73a4425ad4afd1211
    pre sha:a0d4955ba650ace35b7fd411a9670be1032e6982

author	Justin Luth <justin.luth@collabora.com>
tdf#120761 doc import: fix z-order background logic

*** This bug has been marked as a duplicate of bug 120761 ***
Comment 10 Timur 2021-09-15 14:28:23 UTC
Of course, the other bug as later should be a duplicate, but since fix was there, I marked this one as a duplicate.