Download it now!
Bug 49108 - FORMATTING: First Line indent not working in Doc format and/or being lost in conversion
Summary: FORMATTING: First Line indent not working in Doc format and/or being lost in ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-24 06:35 UTC by Rogier van Vlissingen
Modified: 2015-01-27 17:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
word file converted from .odt, with first paragraph indent fixed in word. This file then seems to be interoperable with LO. (95.00 KB, application/msword)
2012-04-24 06:35 UTC, Rogier van Vlissingen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rogier van Vlissingen 2012-04-24 06:35:05 UTC
Created attachment 60527 [details]
word file converted from .odt, with first paragraph indent fixed in word. This file then seems to be interoperable with LO.

Problem description: 

Steps to reproduce:
1. Define a style which starts a paragraph with a first line indent in an .odt or a .doc and apply it 
2. if .odt save the file and convert it to .doc, and the .odt file will retain the first line indent, but the .doc file will have lost the setting in the stylesheet.
3. if .doc the setting will be lost, and the only way to make it work is to open the .doc file in MS Word, and make the change there. Then it will stick, and can even be further edited in LO

Current behavior:
first line indent is lost in .doc files when they are either saved, or converted from .odt. 

Expected behavior:
Should be able to save/retain first line indent formatting

Platform (if different from the browser): 
              
Browser: Opera/9.80 (Windows NT 6.1; WOW64; U; Edition United Kingdom Local; en) Presto/2.10.229 Version/11.62
Comment 1 Joel Madero 2012-12-11 19:30:26 UTC
Confirmed.

Marking:
Version: 3.6.3.2 on Bodhi Linux

New (confirmed)
Normal (can prevent high quality work, interoperability problems with MSO)
High (interoperability, .doc a common format, indented styles relatively common when users are using styles)

Thanks for reporting this one and we'll see if someone can take a look at it soon
Comment 2 QA Administrators 2015-01-05 17:51:56 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 3 Buovjaga 2015-01-27 17:03:07 UTC
Paragraph style 1st line indent in .doc is not lost anymore -> WFM.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36