Bug 49115 - UI: blank document shows empty grey UI background instead of page preview
Summary: UI: blank document shows empty grey UI background instead of page preview
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-24 12:22 UTC by OfficeUser
Modified: 2015-04-19 09:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Calc_recent.png (180.44 KB, image/png)
2015-04-19 09:48 UTC, OfficeUser
Details
Excel_recent.png (185.81 KB, image/png)
2015-04-19 09:48 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2012-04-24 12:22:00 UTC
I think I found to regressions that probably have been introduced by Markus Morhards' changes.

See
https://bugs.freedesktop.org/show_bug.cgi?id=46230#c6
and
https://bugs.freedesktop.org/show_bug.cgi?id=46738#c6


Steps to reproduce:

- Open a blank spreadsheet
- Open the page preview.

==> Note that only a gray area is dispalyed, no page. It is impossible to check header and footer if no cell is filled.

- Try to export as PDF

==> An error message appears: Error saving the document...


Found in LibreOffice 3.5.2.2
Comment 1 Markus Mohrhard 2012-04-24 12:49:48 UTC
Please add this bug to the MAB so that other people can have fun too. And please never ever add me as cc into a bug report.
Comment 2 Kohei Yoshida 2012-04-24 12:54:35 UTC
OfficeUser,

With all due respect, before you accuse a developer by name, you should have a solid evidence of your accusation.  That's a sure way to piss off a developer.

BTW, this behavior has been there since 3.3.  It's not a regression.
Comment 3 OfficeUser 2012-04-24 12:55:55 UTC
@Markus: Reporting your regressions is no fun.
Comment 4 OfficeUser 2012-04-24 12:56:38 UTC
Ok, sorry. Let's examine the problems and than adjust the summary.
Comment 5 OfficeUser 2012-04-24 12:57:44 UTC
"BTW, this behavior has been there since 3.3."

And before 3.3?
Comment 6 Markus Mohrhard 2012-04-24 13:08:36 UTC
Do you really think that any calc dev will now care about your personal bugs? You might start fixing them yourself.
Comment 7 Rainer Bielefeld Retired 2012-04-24 22:25:12 UTC
[Reproducible] with "LibreOffice 3.5.3.1 (RC1) German UI/Locale [Build-ID: 21cb047-d7e6025-9ba54fc-b4a51a8-f42372b] on German WIN7 Home Premium (64bit). all new documents created from File Menu, Start center, WIN Desktop, ... show that empty grey area instead of an empty page, I did not find a setting what might heal that.  

Seems reporter did not check very carefully, I already see that in OOo 1.1.4 (even the PDF export error message is the same), so inherited from OOo and not a regression.

@OfficeUser: 
May I recommend to read <http://wiki.documentfoundation.org/BugReport>, what will help you to write more useful reports? Except the observed effect all report here is unusable and wrong.

Please contribute information concerning your OS.
Comment 8 Terrence Enger 2012-04-25 07:39:47 UTC
print preview
-------------

I have seen the all-grey print-preview before, and I thought it was a
feature rather than a bug.  The workaround is simple: enter
something--even a blank--somewhere in the spreadsheet.

(Bug 48348 "VIEWING FILEOPEN spreadsheet saved from page preview opens
to grey" is different from this one in that the grey background there
arises in a different context and the workaround is even more simple.)


PDF export
----------

The message from the attempt to export an empty document as PDF reads

    Error saving the document Untitled2:
    Write Error.
    The file could not be written.

This is unhelpfully generic.  But still, I suspect that the attempt to
export an empty document is as likely to be accidental as it is to be
intended.  Presumably, the same workaround is effective.
Comment 9 OfficeUser 2012-04-25 10:25:52 UTC
@Terrence: Current behaviour isn't what the user expects and it is not consistent with other LibO applications. ==> bug

@Markus:
I have to apologise. For me it looked like a regression caused by some of your changes since this bug is related with blank cells, too. Again: Sorry.

But I do not think that this is my "personal" bug. All LibO users are affected by such problems.

Could you take this one and provide a patch?
Comment 10 OfficeUser 2012-04-25 10:30:42 UTC
> But still, I suspect that the attempt to
export an empty document is as likely to be accidental as it is to be
intended.

I disagree. Documents can consist of only formattings. Imagine - for example - printing a "blank" table structure for writing by hand...

And again: Current behaviour is inconsistent with other LibO applications.
Comment 11 Rainer Bielefeld Retired 2012-04-25 11:08:00 UTC
@OfficeUser, @Terrence Enger:
This bug has been confirmed, the current behavior is inconsistent to other LibO applications and sometimes a little annoying and so it's a (trivial) bug. I doubt that further discussion will be useful, especially here in this particular bug. 

For the PDF problem I submitted "Bug 49151 - PDF export of Empty sheet causes error message, PRINTING fails silently"!
Comment 12 OfficeUser 2012-05-02 12:24:31 UTC
Corrected summary.
Comment 13 Teo91 2013-09-29 18:19:06 UTC
I can confirm this with LO 4.1.1 on Windows 7 SP1.
Comment 14 QA Administrators 2015-04-01 14:40:17 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 15 OfficeUser 2015-04-12 10:12:13 UTC
Still present in

Version: 4.4.1.2
Build-ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Gebietsschema: de_DE
Comment 16 OfficeUser 2015-04-12 10:13:28 UTC
Additional info to the comment above:

Linux build has been tested
Comment 17 Matthew Francis 2015-04-16 09:37:18 UTC
Occurs in OOo 3.3.0 and earlier, so removing Keywords: regression
Comment 18 OfficeUser 2015-04-19 09:46:40 UTC
I don't consider this a bug anymore.

I see that current builds of MS Excel behave identical. In the meanwhile LibreOffice has been improved so that it indicates (like MS Excel) "No Data". So this doesn't confuse users anymore.

I have attached screen shots of Calc and Excel.

== Closing as RESOLVED WORKSFORME.
Comment 19 OfficeUser 2015-04-19 09:48:09 UTC
Created attachment 114903 [details]
Calc_recent.png
Comment 20 OfficeUser 2015-04-19 09:48:30 UTC
Created attachment 114904 [details]
Excel_recent.png