Bug Hunting Session
Bug 49238 - keyboard hangs when changing sheet name in japanese
Summary: keyboard hangs when changing sheet name in japanese
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-27 21:43 UTC by ananths90
Modified: 2013-01-31 23:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ananths90 2012-04-27 21:43:54 UTC
Debian LibreOffice 3.5.2.2 Build id:350m1(Build:202)

When I change the name of the Calc worksheet to anything using Japanese language, the keyboard stops working. I am unable to enter or edit anything afterwards.

Mouse actions work, so I am able to save the file. Once I reopen the file, I can continue as normally. 

I am using the Japanese localization of the default debian build from sid.
Comment 1 Naruhiko Ogasawara 2013-01-30 05:07:48 UTC
With LibreOffice 3.6.2.2 (Build ID: 360m1(Build:2)) and  4.0.0.2 (Build ID: 408fe71bd18616c467b3dcd7ab6756528ffcae2)
on Ubuntu 12.10 (Linux <hostname> 3.5.0-22-generic #34-Ubuntu SMP Tue Jan 8 21:41:11 UTC 2013 i686 i686 i686 GNU/Linux

I can't reproduce this issue. Renaming worksheet using Japanese cause no effect, I can continue the editing.

My Japanese input method is:

  ibus-mozc   1.5.1090.102-2ubuntu1


@ananths90: you still have the problem?
What IM you use?
Please let us know.
Comment 2 Jorendc 2013-01-31 23:56:39 UTC
(In reply to comment #1)
> With LibreOffice 3.6.2.2 (Build ID: 360m1(Build:2)) and  4.0.0.2 (Build ID:
> 408fe71bd18616c467b3dcd7ab6756528ffcae2)
> on Ubuntu 12.10 (Linux <hostname> 3.5.0-22-generic #34-Ubuntu SMP Tue Jan 8
> 21:41:11 UTC 2013 i686 i686 i686 GNU/Linux
> 
> I can't reproduce this issue. Renaming worksheet using Japanese cause no
> effect, I can continue the editing.

Thanks for testing.

Therefore I mark this as RESOLVED WORKSFORME

@Bug reporter: if this bug is still reproducible, please feel free to REOPEN.

Kind regards,
Joren