Bug Hunting Session
Bug 49260 - Misplaced images and some other graphics in docx files
Summary: Misplaced images and some other graphics in docx files
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx
Depends on: 103056 117925
Blocks: Writer-Images DOCX-Images
  Show dependency treegraph
 
Reported: 2012-04-28 12:13 UTC by Ruslan Kabatsayev
Modified: 2018-05-31 06:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (161.48 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-04-28 12:13 UTC, Ruslan Kabatsayev
Details
How it looks in LO Writer (134.44 KB, image/png)
2012-04-28 12:14 UTC, Ruslan Kabatsayev
Details
How it should look (107.50 KB, image/png)
2012-04-28 12:14 UTC, Ruslan Kabatsayev
Details
example 2 file (731.59 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-11-13 12:08 UTC, Roman Polach
Details
example 2 screenshot in MS office 2007 - how it should look (696.97 KB, image/png)
2012-11-13 12:09 UTC, Roman Polach
Details
example 2 - screenshot of LibreOffice 3.6.3 - not good (397.89 KB, image/png)
2012-11-13 12:09 UTC, Roman Polach
Details
example 2 - screenshot in ancient OOo 3.1.1 - suprisingly almost good (390.23 KB, image/png)
2012-11-13 12:10 UTC, Roman Polach
Details
Screenshot as of LibO 6.0 Beta1 (248.04 KB, image/png)
2017-12-08 09:25 UTC, Ruslan Kabatsayev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Kabatsayev 2012-04-28 12:13:40 UTC
Created attachment 60745 [details]
Test file

See this test file. It looks very different in Word and Writer. I'll add screenshots for comparison.
Comment 1 Ruslan Kabatsayev 2012-04-28 12:14:14 UTC
Created attachment 60746 [details]
How it looks in LO Writer
Comment 2 Ruslan Kabatsayev 2012-04-28 12:14:38 UTC
Created attachment 60747 [details]
How it should look
Comment 3 Roman Polach 2012-11-13 12:08:19 UTC
I have another example of the same problem...
attaching with a MS-Office-2007 screenshot,
LibreOffice-3.6.3 screenshot and also an
OOo-3.1.1-screenshot which is suprisingly
a bit better than latest LibreOffice (but
still not perfect)
Comment 4 Roman Polach 2012-11-13 12:08:40 UTC
Created attachment 69995 [details]
example 2 file
Comment 5 Roman Polach 2012-11-13 12:09:21 UTC
Created attachment 69996 [details]
example 2 screenshot in MS office 2007 - how it should look
Comment 6 Roman Polach 2012-11-13 12:09:54 UTC
Created attachment 69997 [details]
example 2 - screenshot of LibreOffice 3.6.3 - not good
Comment 7 Roman Polach 2012-11-13 12:10:35 UTC
Created attachment 69998 [details]
example 2 - screenshot in ancient OOo 3.1.1 - suprisingly almost good
Comment 8 Ruslan Kabatsayev 2013-01-03 00:07:43 UTC
"Test file" test looks almost good in image placement in Version 4.1.0.0.alpha0+ (Build ID: ca3aba4cdf766cf33b0dbbe495c9e6f57f06982). Still, the vector image at the end is messed up (it's a separate bug though), but its position looks (almost) correct.
As for Roman Polach's "example 2 file", it is still messed up in this version. Moreover, the images appear to jump from page to page as the document view is scrolled and scaled, and these jumps result in total page count changes.
Comment 9 Alexandr 2014-08-18 10:15:39 UTC
LibreOffice freezes when I try to scroll example2. I reported it as bug 82762.
Comment 10 QA Administrators 2015-09-04 02:47:59 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2015-11-18 11:33:22 UTC
Still looks messy in the end.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 12 Robinson Tryon (qubit) 2015-12-13 12:18:24 UTC Comment hidden (obsolete)
Comment 13 Telesto 2016-11-15 19:29:18 UTC
I can confirm example 2:
Version: 5.3.0.0.alpha1+
Build ID: bb50b1609abe83265311613db4a18e992dc666c8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-14_23:25:25
Locale: nl-NL (nl_NL); Calc: CL
Comment 14 QA Administrators 2017-12-08 08:06:19 UTC Comment hidden (obsolete)
Comment 15 Ruslan Kabatsayev 2017-12-08 09:22:14 UTC
My test file looks almost correct, although the arrows and text labels are still not placed precisely enough. The example file from comment 4 is still broken (first page doesn't show what the screenshot of MSO2007 does), and any attempt to display second page hangs Writer.

Tested on:
Version: 6.0.0.0.alpha1
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Linux 3.16; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 16 Ruslan Kabatsayev 2017-12-08 09:25:46 UTC
Created attachment 138298 [details]
Screenshot as of LibO 6.0 Beta1

Here's how the first test file looks in LibO 6.0 Beta1.
Comment 17 Timur 2018-01-12 10:04:06 UTC
This is one of those older "document based" bugs that's not properly triaged in order to have "issue based" bugs. 
Bugzilla is "issue based", so a single issue must be pointed at, after a search for not being a duplicate. 
Bugzilla is not "document based", like "this document doesn't display nice". 
And those bugs may stay open for a long time, unlikely that anyone will look at them.

As for attachment 60745 [details], looks nice except last shape (it's not image). That one looks worse as original 2007 docx and better if saved as 2013 docx. Should be reported separately. I'm not an optimist due to a number of open shapes bugs.

Attachment 69995 [details] is unrelated, it's about images order and handling and LO freezes. 9 images on 3 pages. I'll report separately, although there are many bugs for images handling. This is a good example to test it. 

So I'll close this one as Invalid.
Comment 18 Timur 2018-01-12 10:40:52 UTC
Example 2 already had it+'s own bug.