Bug 49269 - FILESAVE: Saving as RTF: new line before č and removing of letter after č
Summary: FILESAVE: Saving as RTF: new line before č and removing of letter after č
Status: RESOLVED DUPLICATE of bug 48356
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on: 82762
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-29 03:36 UTC by opensuse.lietuviu.kalba
Modified: 2018-01-12 10:43 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2012-04-29 03:36:34 UTC
Problem description: 
I had RTF document created with WordPad in Microsoft Windows 7.
It was opened correctly in LibreOffice, but I did some modifikations and saved it. After saving, text was corrupted near these letters: č, ė, ū. Opening in MS WordPad also show corrupted text. So I decided, that this is problem with saving. 
Then I created new document with text "Tačiau" and saved it; reopened well.
Then I marked all text, in font name field manually entered "Calibri" , pressed Enter, saved document again. Reopened document and see corrupted text: before some letters (e.g., ė, č, ū) new lines added; after these letters – missing some letters.


Steps to reproduce:
1. Write text with letter č (for example, "Tačiau")
2. Save document as RTF
3. Reopen document
4. Force to change font to not installed font "Calibri"
5. Save document again
6. Reopen document

Current behavior:
I see:
"Ta
čau"


Expected behavior:
I see:
"Tačiau"

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 opensuse.lietuviu.kalba 2012-04-29 04:29:56 UTC

*** This bug has been marked as a duplicate of bug 48356 ***