Download it now!
Bug 49401 - FORMATTING: SVG font error when embedding image into a Writer document
Summary: FORMATTING: SVG font error when embedding image into a Writer document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) Windows (All)
: high trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 47964 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-02 13:03 UTC by zazy
Modified: 2015-06-20 12:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A simple document with only the SVG file embedded (16.57 KB, application/vnd.oasis.opendocument.text)
2012-05-02 13:03 UTC, zazy
Details
SVG "squares" bug as shown on my Win7 Professional x86 box (113.88 KB, image/jpeg)
2012-10-08 06:57 UTC, zazy
Details
SVG "squares" bug as shown on my Ubuntu 12.04 LTS x64 box (76.87 KB, image/png)
2012-10-08 07:01 UTC, zazy
Details
SVG of embedded file (4.80 KB, image/svg+xml)
2012-10-11 14:30 UTC, zazy
Details
Screenshot SvgFontOk.png (9.17 KB, image/png)
2013-04-01 14:34 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zazy 2012-05-02 13:03:32 UTC
Created attachment 60930 [details]
A simple document with only the SVG file embedded

Problem description: 
Wrong font rendering in embedded SVG files.

Steps to reproduce:
1. Crete new document
2. Go to Insert->Image->From file menu
3. Choose an SVG image

Current behavior:
the font of the embedded svg file is showed as e sequence of rectangles

Expected behavior:
The text should be rendered with the choosed font inside the svg file.

Platform (if different from the browser): 
Windows 7 Professional x64

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

In Linux Kubuntu Oneiric 11.10 the attached file is showed correctly.
The font is well configuerd in my Windows environment and the rectangles are shown also if i choose Verdana as font.
My linux box is an x64 machine with x64 SysOp and x64 Libreoffice. 
My Windows 7 box is an x64 machine with x64 SysOp and x32 LibreOffice (LibreOffice is not available in x64 version for Windows)
Comment 1 madmuffin 2012-06-01 14:42:35 UTC
correcting platform ia64 -> x86-64
Comment 2 Joel Madero 2012-10-08 04:20:04 UTC
I'm marking this as WORKSFORME as the attached file looks perfect to me. I'm running LibO 3.6.1.2. 

If this is still a problem for you with the latest stable release please reopen this as UNCONFIRMED, attach another document if possible (not necessary though), a screenshot of what you see could be helpful. Also let us know what version you're testing on. 

Thanks for helping out
Comment 3 zazy 2012-10-08 06:33:10 UTC
It's stille there for me. On my linux box it works fine (Ubuntu 12.04 LTS). Still showing sqares on Windows 7 Professional.

Joel on which platform you tested on?
Comment 4 zazy 2012-10-08 06:57:24 UTC
Created attachment 68243 [details]
SVG "squares" bug as shown on my Win7 Professional x86 box
Comment 5 zazy 2012-10-08 07:01:24 UTC
Created attachment 68244 [details]
SVG "squares" bug as shown on my Ubuntu 12.04 LTS x64 box
Comment 6 zazy 2012-10-08 07:09:44 UTC
Joel i attached two screenshots.

The first one (attachment #68243 [details]) is taken from an x86 system running Windows 7 Professional and LibreOffice 3.6.2.2

The second one (attachment #68244 [details]) is taken from an x64 system running Ubuntu linux 12.04 LTS and LibreOffice 3.6.0.2 (the zero here is not a mistyping)

The font should be embedded in the svg inserted inside the document but i obtain same result if i install the font in Windows.

Please let me know if you need further details.
Comment 7 Joel Madero 2012-10-08 16:34:56 UTC
My mistake, I did test on Linux, should have paid more attention to the platform. Will test it out today on another machine that has Windows. Thanks for the update and info
Comment 8 leighman 2012-10-08 17:06:17 UTC
Please could you attach the original svg file here too.

Are you saying in comment #6 that it works on Windows if you install the correct font?

Certainly LibO should be falling back more gracefully on Windows by the look of it.
Comment 9 zazy 2012-10-11 14:30:16 UTC
Created attachment 68440 [details]
SVG of embedded file

This is the SVG file embedded in attachment #60930 [details]
Comment 10 zazy 2012-10-11 14:37:34 UTC
leighman i attached the SVG file used for embedding.

What i wanted to say in comment #6 is that even if font is embedded in the svg, i tryed to install it in Windows fonts but result is the same. This was made just to try to understand if LibreOffice was not able to use the svg embedded font.
Comment 11 pierre-yves samyn 2012-10-15 07:20:15 UTC
Hello

I confirm with Windows 7 64bits and :
- Version 3.6.2.2 (Build ID: da8c1e6)
- Version 3.6.4.0+ (Build ID: a010c4e)

Also reproduce (fr-qa) with Win7 & LibO 3.5.7RC2 & LibO 3.6.2.

On this platform, the attached SVG showed correctly with Firefox & AOO 3.4.0.

Regards
Pierre-Yves
Comment 12 pierre-yves samyn 2013-04-01 14:34:02 UTC
Hello

Worksforme with Windows 7 64bits &
Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)

See SvgFontOk.png

Regards
Pierre-Yves
Comment 13 pierre-yves samyn 2013-04-01 14:34:41 UTC
Created attachment 77274 [details]
Screenshot SvgFontOk.png
Comment 14 Ulrich Windl 2013-08-30 09:31:02 UTC
I also see this bug in LibreOfficeWriter  3.6.7: I produced an SVG file with gnuplot on Linux, using font "Helvetica". When importing the image on Windows7 every character is displayed as an empty rectancle. However if I open the same file on the same machine with Inkscape, the characters are displayed correctly.
So I guess Inkscape is using a replacement font, while Writer does not.
In any case the current situation is bad: Either use a replacement font (and warn the user), or warn that the font could not be found. Not doing either is the worst decision (IMHO). If needed, I can provide my SVG here, also.
Comment 15 ign_christian 2013-08-30 14:32:02 UTC
*** Bug 47964 has been marked as a duplicate of this bug. ***
Comment 16 Björn Michaelsen 2014-01-17 00:43:41 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 17 Joel Madero 2015-05-02 15:41:12 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 18 Buovjaga 2015-06-20 12:14:09 UTC
Works ok.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)