Download it now!
Bug 49406 - blank area between end of line and concave arrow
Summary: blank area between end of line and concave arrow
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-02 15:56 UTC by avi9526
Modified: 2016-01-04 21:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Image to illustrate the problem with my markers (red) (204.25 KB, image/png)
2012-05-02 15:56 UTC, avi9526
Details
line properties dialog screenshot (16.97 KB, image/png)
2014-10-24 21:09 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description avi9526 2012-05-02 15:56:00 UTC
Created attachment 60944 [details]
Image to illustrate the problem with my markers (red)

Problem description: 

Steps to reproduce:
1. Open new odg file with Draw
2. Add two rectangle
3. Add the "Connector with arrows" that connecting this two rectangles
4. Select this connector and go to "Line" properties dialog.
4.1. Set the line width to "1mm"
4.2. Set "Arrow styles"->"Style" to "Arrow concave".
4.3. Set "Arrow styles"->"Width" to "3mm".
4.4. Hit "OK"
5. Zoom in to see problem

Current behavior:
arrow don't touch the end of a line

Expected behavior:
arrow must touch the end of a line

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Jean-Baptiste Faure 2012-05-06 08:00:26 UTC
Reproducible even with master (Build ID: 32af02b) under Ubuntu 11.10 x86_64.

Best regards. JBF
Comment 2 tommy27 2014-10-24 21:09:32 UTC
Created attachment 108372 [details]
line properties dialog screenshot

are you sure that this is really a bug? 

from what I see the "arrow concave" style is supposed to be like that...
if you take a close look at my screenshot you can see that that arrow style has a space between line and arrow even in the dropdown preview menu.

so it looks to me that that's was the way it was designed...
if you don't like that space use a different arrow style where all elements are contiguous
Comment 3 QA Administrators 2015-12-20 16:06:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 4 Jean-Baptiste Faure 2016-01-04 21:24:27 UTC
(In reply to tommy27 from comment #2)
> Created attachment 108372 [details]
> line properties dialog screenshot
> 
> are you sure that this is really a bug? 
> 
> from what I see the "arrow concave" style is supposed to be like that...
> if you take a close look at my screenshot you can see that that arrow style
> has a space between line and arrow even in the dropdown preview menu.
> 
> so it looks to me that that's was the way it was designed...

Indeed, I think you are right. Closing as NotABug.

Best regards. JBF