Bug 49514 - Search / Find 'continue at the beginning' skips / ignores previous footnotes
Summary: Search / Find 'continue at the beginning' skips / ignores previous footnotes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.6 release
Hardware: All Linux (All)
: highest minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-04 15:43 UTC by ryan.jendoubi@gmail.com
Modified: 2016-04-23 19:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Demo document - 2 footnotes (9.19 KB, application/vnd.oasis.opendocument.text)
2012-05-04 15:43 UTC, ryan.jendoubi@gmail.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ryan.jendoubi@gmail.com 2012-05-04 15:43:29 UTC
Created attachment 61058 [details]
Demo document - 2 footnotes

When Writer's Find / Find & Replace functions cannot find the requested text between the current cursor location and the end of the document, a dialog appears saying "LibreOffice Writer has searched to the end of the document. Do you want to continue at the beginning"?

If one clicks "Yes", and the searched term is in the preceding main text of the document, it will be found.

HOWEVER, if the searched term is in a *footnote* further back in the document before the current cursor location, it will *not* be found.

I'd appreciate if people could check whether this bug appears in 3.5, and on other platforms.

= Steps to reproduce =
1. Open attached document (Word "foo" with footnote "bar", word "baz" with footnote "qux").
2. Position cursor in footnote 2 (with the word "qux").
3. Open Find / Find & Replace and try to search for "foo". Search will loop back and find "foo" at the start of the document.
4. Re-position cursor in footnote 2 (with the word "qux").
5. Open Find / Find & Replace and try to search for "baz" (which is in footnote 1).
Result: after looping back to the start of the document, "baz" will still not be found.
Comment 1 Joel Madero 2012-09-16 22:58:44 UTC
Verified, setting as NEW + prioritizing.

LO: Version 3.6.1.2 (Build ID: e29a214)


Minor: Doesn't prevent professional quality work but makes it harder to trust search + replace feature. 

Highest: Could potentially lead to misspellings in footnotes. Also could affect quite a few users.
Comment 2 raf.jaf 2013-06-30 12:17:38 UTC
Hello, could this bug perhaps receive a higher priority? It is very annoying when working with big documents with lot of footnotes. I thank you in advance.
Comment 3 Joel Madero 2013-07-01 02:37:02 UTC
It is at the appropriate priority - if you want it fixed faster perhaps pay a developer or look into the code. Our devs are currently working on crasher bugs and more serious issues than this one which just slows down work - I agree it's annoying therefore the "highest"
Comment 4 Björn Michaelsen 2014-01-17 00:43:24 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 5 Sulphur 2014-06-19 00:36:18 UTC
I always wondered what was happening when I missed finding certain words in Writer. I've messed up editing some important documents due to this bug. Thank you Ryan for at least describing the exact problem (I only vaguely knew it had something to do with footnotes).
Comment 6 Sulphur 2015-03-28 18:26:07 UTC
Still a problem in version 4.4.1.2.
Comment 7 Sulphur 2016-04-23 19:44:21 UTC
Not sure when this happened, but the problem seems fixed now in the 5.1 series (at least it is in 5.1.2.2 on Ubuntu 16.04)!
Comment 8 Joel Madero 2016-04-23 19:48:54 UTC
Closing as WFM - if someone else still sees it set it back to NEW and leave your version and OS. Thanks!