Bug 49650 - : Menus aligend to the left on second monitor
Summary: : Menus aligend to the left on second monitor
Status: RESOLVED DUPLICATE of bug 46469
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: David Tardon
QA Contact:
URL:
Whiteboard: BSA bibisected35
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-05-08 10:03 UTC by Dan
Modified: 2012-06-20 01:59 UTC (History)
2 users (show)

See Also:


Attachments
Screenshot showing menu cascading to the left (36.15 KB, image/png)
2012-05-10 12:06 UTC, Ian Pilcher
Details
Screenshot showing overlapping menus (28.11 KB, image/png)
2012-05-10 12:06 UTC, Ian Pilcher
Details
git bisect log (1.64 KB, text/plain)
2012-05-10 23:14 UTC, Ian Pilcher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2012-05-08 10:03:11 UTC
Problem description: On CentOS 6.2 (KDE 4.3.4), LibreOffice windows on the second monitor open all menus (incl. context menus) to the *LEFT* instead of to the *RIGHT*. This results in sub-menus opening *over* parent the menu instead of to the right (see attached screenshot).
This has been reported so far for Ubuntu as well (https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/952325).

Steps to reproduce:
1. Open LibreOffice on the second monitor
2. Click for any menu (e.g., File)
3. The menu is aligned to the left instead of to the right

Current behavior:
Menus aligned to the left on second monitor

Expected behavior:
Menus aligned to the right on the second monitor as they do on the primary monitor (and all other applications, including OpenOffice 3.2 on the same machine & OS).

Platform (if different from the browser): 
CentOS 6.2 KDE 4.3.4              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.4) Gecko/20120425 Firefox/10.0.4

Thanks,
Dan
Comment 1 Ian Pilcher 2012-05-10 11:53:05 UTC
I am seeing this on Fedora 17, libreoffice-core-3.5.2.1-6.fc17.x86_64.

Very annoying.
Comment 2 Ian Pilcher 2012-05-10 12:06:19 UTC
Created attachment 61383 [details]
Screenshot showing menu cascading to the left
Comment 3 Ian Pilcher 2012-05-10 12:06:57 UTC
Created attachment 61384 [details]
Screenshot showing overlapping menus
Comment 4 Ian Pilcher 2012-05-10 21:40:28 UTC
I have just confirmed that this problem also occurs with the 3.5.3 RPMS from http://www.libreoffice.org/download/
Comment 5 Ian Pilcher 2012-05-10 23:08:45 UTC
According to the "bibisect" technique described at http://sweetshark.livejournal.com/7683.html, the first bad commit is one of the following:

commit e279a23b4a849f4a24050fbe668c12f81a45fb02
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Dec 8 03:00:33 2011 +0100

    source-hash-a39f4e5b57f5e518cc1ba09d5801da07b52fbaa5
    
    commit a39f4e5b57f5e518cc1ba09d5801da07b52fbaa5
    Author:     Michael Meeks <michael.meeks@suse.com>
    AuthorDate: Wed Sep 28 18:09:40 2011 +0100
    Commit:     Michael Meeks <michael.meeks@suse.com>
    CommitDate: Tue Oct 25 13:41:45 2011 +0100
    
        gtk3: substantial re-work and cleanup of event handling
    
        Implement SalTimer ourselves rather more cleanly
        Remove nasty GtkXLib cruft inherited from X backend
        Merge and cleanup most Yield / mainloop bits into GtkData

commit 860351a174dea414f94654859c7c9cacf14fa102
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Dec 8 03:20:07 2011 +0100

    source-hash-2175576c120806f8415be7ab2051ba639a18f564
    
    commit 2175576c120806f8415be7ab2051ba639a18f564
    Author:     Tor Lillqvist <tlillqvist@suse.com>
    AuthorDate: Wed Oct 26 09:43:48 2011 +0300
    Commit:     Tor Lillqvist <tlillqvist@suse.com>
    CommitDate: Wed Oct 26 09:43:48 2011 +0300
    
        WaE: unreferenced local variable
Comment 6 Ian Pilcher 2012-05-10 23:14:47 UTC
Created attachment 61415 [details]
git bisect log
Comment 7 Ian Pilcher 2012-05-10 23:29:03 UTC
Reviewing the contents of the two commits, I'm 99.999% sure that 	a39f4e5b57f5e518cc1ba09d5801da07b52fbaa5 is the problematic one.
Comment 8 David Tardon 2012-06-20 01:59:53 UTC

*** This bug has been marked as a duplicate of bug 46469 ***