Bug 49676 - EDITING: Built-In Image Editor
Summary: EDITING: Built-In Image Editor
Status: RESOLVED DUPLICATE of bug 34555
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-09 02:02 UTC by Ade Malsasa Akbar
Modified: 2016-07-07 13:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ade Malsasa Akbar 2012-05-09 02:02:44 UTC
I think a new built-in image editor for Writer will be a great feature because many times I create tutorials, I insert many images as is. I insert many images without any editing, without any cropping. So I should edit all of my pictures after my document done.

It is great if LibreOffice Writer has build-in/internal image editor, even if the image editor only can do cropping. Okay sure, if it can do many tasks, it will be more advantageous and more efficient. But I like even if there is a crop feature only provided. And developer maybe has known, outside there people (sometimes) only have office suite and don't have any image editor. And I admit if it will be easier, comforter, more advanced if Writer can do this internally. So people dont need to open GIMP or Shotwell or Paint anymore. Enough with Writer.

I get this idea from Shutter and Microsoft Office. That's all of my idea.
Comment 1 Joel Madero 2012-12-11 19:44:17 UTC
I'm marking this as NEW and an enhancement request

Marking as LOW priority because of how difficult it is to implement plus there are tools (I know these are harder to use) that can effectively do these things, definitely would be nice to have a built in editor.

What I can warn is that this is a tremendous undertaking and will require a ton of work by any developer. Because of this it's unlikely to happen in the near future, our team is really stretched thing. Maybe going forward a team of developers will take this on. Also see https://bugs.freedesktop.org/show_bug.cgi?id=34423, which is a similar request (but just for rotating images)
Comment 2 Timur 2014-05-07 16:55:27 UTC
I thing this may be marked as a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=34555.
Comment 3 Samuel Mehrbrodt (CIB) 2016-07-07 13:41:28 UTC

*** This bug has been marked as a duplicate of bug 34555 ***