Bug 49679 - odf_validation in styles.xml: Element p has extra content: span
Summary: odf_validation in styles.xml: Element p has extra content: span
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5 Daily
Hardware: Other All
: medium normal
Assignee: Michael Stahl (allotropia)
URL: https://wiki.documentfoundation.org/i...
Whiteboard: odf odf_validation
Keywords:
Depends on:
Blocks: 49569
  Show dependency treegraph
 
Reported: 2012-05-09 02:44 UTC by Rainer Bielefeld Retired
Modified: 2012-09-13 17:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-05-09 02:44:57 UTC
Document source: See URL

Steps how to reproduce: Download sample document, open with LibO Version mentioned below, then do validator tests

Text document saved with:  LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit) 
PDF File Format: 1.2 Extended

Validation results (+ = ok, - = not ok), Message behind
+ odf-validator.rhcloud: no such error detected?
+ Officeotron: ./.
+ Cyclone: Element p has extra content: span. May be related:
                  Element master-page has extra content: frame
                  Extra element master-page in interleave
                  Element master-styles failed to validate content 
+ ODFToolkit: not tested, HTTP ERROR 412
+ opendocumentfellowship: only ODF1 tests possible
Comment 1 Rainer Bielefeld Retired 2012-05-09 03:12:45 UTC
You find a complete test report copy in Bug 49677
Comment 2 Michael Stahl (allotropia) 2012-09-13 17:29:32 UTC
these "Cyclone" errors don't make any sense to me:
text:span inside text:p and draw:frame inside draw:master-page
are valid nestings.

also there isn't any position information in the errors,
so it looks like a pretty useless tool to me.
Comment 3 Michael Stahl (allotropia) 2012-09-13 17:30:15 UTC
hmm perhaps NOTOURBUG is more fitting here :)