Bug 49741 - PRINTING: ENHANCEMENT - poor print time performance on Mac OS X compared to other OSX apps
Summary: PRINTING: ENHANCEMENT - poor print time performance on Mac OS X compared to o...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: MacOS-Wishlist Print
  Show dependency treegraph
 
Reported: 2012-05-10 10:09 UTC by DB
Modified: 2018-10-18 19:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
test text file (3.18 KB, application/x-shellscript)
2012-09-05 07:50 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DB 2012-05-10 10:09:43 UTC
When sending files to the printer, it takes about 1 min for LO to send the file to the printer. This is true even for 1 page documents. This appears to be a carryover problem from OO. This is also just a problem with LO and OO, as other programs start printing instantly.
Comment 1 Roman Eisele 2012-09-04 08:01:01 UTC
@Alex Thurgood:

Hello Alex,
this is another Mac OS printing issue, minor, but annoying. Having recently dealt with other printing issues, could you please take a look at this one and try if you can confirm it? (I still can’t test printing issues.)
Thank you!
Comment 2 Alex Thurgood 2012-09-05 07:38:04 UTC
(In reply to comment #1)
> @Alex Thurgood:
> 
> Hello Alex,
> this is another Mac OS printing issue, minor, but annoying. Having recently
> dealt with other printing issues, could you please take a look at this one and
> try if you can confirm it? (I still can’t test printing issues.)
> Thank you!

Hi Roman,

Haven't noticed anything in particular, as I print over the network, but will have a look, compare between different apps. This may just be suboptimal CUPS instruction processing in the LO code...


Alex
Comment 3 Alex Thurgood 2012-09-05 07:42:22 UTC
(In reply to comment #0)
> When sending files to the printer, it takes about 1 min for LO to send the file
> to the printer. This is true even for 1 page documents. This appears to be a
> carryover problem from OO. This is also just a problem with LO and OO, as other
> programs start printing instantly.


Hi,

As you imply that the problem was already present in OOo, then it would appear that this is not a bug as such, since the functionality works per se, but a request for enhancement, i.e. improvement of an existing feature, namely speed performance with printing operations.

I print over the network to two different printers from LO on Mac, and have not noticed any particular slowness. In order for your request to even have a hope of being considered, you might like to provide some comparative data, along with your machine specs, network setup if printing over network, etc, otherwise everything else is just rather subjective.

Alex
Comment 4 Alex Thurgood 2012-09-05 07:50:39 UTC
Created attachment 66661 [details]
test text file
Comment 5 Alex Thurgood 2012-09-05 07:57:34 UTC
With LibreOffice 3.5.6.2 
Build ID: e0fbe70-dcba98b-297ab39-994e618-0f858f0

Printing the attached simple text document to a LAN 100Mb networked Kyocera FS C5150DN printer took : 

1 min 18 sec

Printing the same document from TextWrangler to the same printer from the same machine took under the same network/process load :

24 sec 


Those are the kind of figures we want to have as a comparison. If I were to judge printing performance based on the above figures alone, I would say we have a printing performance problem... 


Alex
Comment 6 Alex Thurgood 2012-09-05 07:59:03 UTC
Changing title to reflect specifics of the situation
Comment 7 Alex Thurgood 2012-09-05 08:01:41 UTC
Same data, same machine/network/printer/load :

Textedit : 25 secs
Comment 8 Alex Thurgood 2012-09-05 08:03:52 UTC
@Thorsten, Norbert : yet another performance enhancement request for Mac OSX...
Comment 9 Alex Thurgood 2012-09-05 08:04:25 UTC
Just for the record, my tests were all carried out on OSX 10.8.1
Comment 10 Roman Eisele 2012-09-05 08:44:04 UTC
@Alex:
Again, thank you for all your research about this issue! The figures (comment #5, comment #7) are impressive, of course ...

Changed Component to "Printing", because this issue seems common to all LibreOffice components (the original report was for spreadsheet [Calc], but Alex’ tests are using text files [Writer]).