Bug 49837 - 3.5.3 not recognized in MAC
Summary: 3.5.3 not recognized in MAC
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-12 07:18 UTC by luchotres
Modified: 2012-09-07 14:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luchotres 2012-05-12 07:18:54 UTC
Problem description: 

Steps to reproduce:
1. ....download 3.5.3 version language package (spanish)
2. ....install 3.5.3 and language package (spanish)
3. ....start

Current behavior:
advice: new version avaiable
The installed version is
LibreOffice 3.5.2.2 
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f

Expected behavior:
should be installed 3.5.3

Platform (if different from the browser): 
Mac OS X 10.6.8
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.55.3 (KHTML, like Gecko) Version/5.1.5 Safari/534.55.3
Comment 1 Roman Eisele 2012-05-23 03:06:43 UTC
Thank you very much for your report!

However, I have not seen this problem with my default (German) installation of LibreOffice 3.5.3, and I can NOT REPRODUCE it on my machine (using MacOS X 10.6.8 like you). To test, I did a fresh install of LibreOffice 3.5.3.2, installed the Spanish langpack, set both the System UI language and the LibreOffice UI language to Spanish/Spain, but the About box says correctly

LibreOffice 3.5.3.2 
Build ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80

and when I select "Get Info" in the Finder for the LibreOffice application, the Information window also says "3.5.3".

However, the different Build ID quoted by you shows that not only the version number is wrong, but that you really have another build. You are right, there must be a problem somewhere, of course ...

Therefore, I wanted to ask you to do another, clean install of 3.5.3, after manually deleting (!) the old version of the LibreOffice application before (to avoid any confusion and installation mistakes), but LibreOffice 3.5.4 is coming soon, and so I don't want to waste your time.

Could you, please, when LibreOffice 3.5.4 is out, try the following:
1) Go to the Applications folder of your Mac, search LibreOffice and delete the complete "LibreOffice" application (just to ensure that there is no confusion of application files etc.).
2) Download LibreOffice 3.4.5 from http://www.libreoffice.org/, together with the language pack ("Translated User Interface") of your choice
3) Install LibreOffice 3.4.5 and then the language pack
4) Check again the LibreOffice Version both in the "About LibreOffice" window and with the Finder's Get Info feature
5) Report here again if the version is correct this time (i.e., 3.5.4.x) or wrong again?!

This would be very helpful, and you may want to download 3.5.4 anyway, as it contains many useful fixes ;-) Thank you very much!
Comment 2 Roman Eisele 2012-05-23 03:09:41 UTC
(In reply to comment #1)

> 2) Download LibreOffice 3.4.5 from http://www.libreoffice.org/, together with
> the language pack ("Translated User Interface") of your choice
> 3) Install LibreOffice 3.4.5 and then the language pack
> 4) Check again the LibreOffice Version both in the "About LibreOffice" window
> and with the Finder's Get Info feature.

Correction: I wanted to write "LibreOffic 3.5.4" (!), of course, in any place, not "3.4.5". Sorry!
Comment 3 Roman Eisele 2012-06-17 01:51:40 UTC
@luchotest:

I wrote:
> Could you, please, when LibreOffice 3.5.4 is out, try the following:
> ...

Now 3.5.4 is out for some days, and it would be very very helpful if you could please try what I proposed in comment #1. Thank you very much in advance!
Comment 4 Roman Eisele 2012-09-07 14:16:17 UTC
Dear bug reporter,

I am sorry but we need to close this bug report, because the important questions given in comment #1 have not been answered for more than three months now. Without any answers, we can’t proceed with this bug report in any way, and therefore we close it.

Feel fre to reopen this bug report if you can still/again reproduce the same (!) issue with a current version of LibreOffice, i.e. 3.5.6 or 3.6.1 or better.

Thank you!