Bug 49874 - EDITING: CRASH when selecting Format -> Page while an picture is currently selected
Summary: EDITING: CRASH when selecting Format -> Page while an picture is currently se...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-13 10:48 UTC by david berndt
Modified: 2012-06-17 06:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
problematic file (2.16 MB, application/vnd.oasis.opendocument.text)
2012-05-14 14:00 UTC, david berndt
Details
freeze screenshot (381.28 KB, image/png)
2012-05-14 14:20 UTC, david berndt
Details
gdb.log (91.15 KB, application/zip)
2012-05-14 15:51 UTC, david berndt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description david berndt 2012-05-13 10:48:42 UTC
1. insert image
2. click inserted image (box should surrounding image)
3. Format -> Page
4. enjoy writer being locked up
Comment 1 Rainer Bielefeld Retired 2012-05-13 22:37:57 UTC
NOT rReproducible with "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit)

Linux only?

Not reproducible with Ubuntu64 + LibO 3.4.4

@david berndt:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version (with Build ID if it's not a public release)
     and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts
Comment 2 Julien Nabet 2012-05-14 13:22:46 UTC
On pc Debian x86-64, branch 3.5 updated today (cf90a279a4ba18e73067b7a978af5ef1f1b98e27), tested with a png image, I've got the dialog window which displays normally.
 
Is it a freeze or a crash ?
Do you reproduce this with any format image ?
Do you have specific LO extensions ?
Did you try with a brand new LO profile (see http://wiki.documentfoundation.org/UserProfile) ?

If possible and if you still reproduce this, could you try to retrieve a useful backtrace by following this link ? (http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29)
Comment 3 david berndt 2012-05-14 14:00:10 UTC
Created attachment 61651 [details]
problematic file
Comment 4 david berndt 2012-05-14 14:19:45 UTC
I can only reproduce the problem intermittently today and only on my Linux computer.  I have not be able to reproduce the issue on this issue on my win7 x86 computer.

Linux computer
Ubuntu 12.04
3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

LibreOffice 3.5.3.2
Build ID: 350m1(Build:2)

The best method of attempting to reproduce this error is to edit the pictures (right click image -> Pictures) modify the size of the picture and accept changes.  Then select Format -> Page.  Repeat the process of modifying images and selecting Format -> Page and eventually the program freezes.  By this I mean the program stops responding and I must force quit.

I open the program by selecting the shortcut on my taskbar and navigating to recent documents or by selecting the file directly.


(In reply to comment #1)
> NOT rReproducible with "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID:
> 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit)
> 
> Linux only?
> 
> Not reproducible with Ubuntu64 + LibO 3.4.4
> 
> @david berndt:
> Thank you for your report – unfortunately important information is missing.
> May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to
> find out what information will be useful to reproduce your problem? If you
> believe that that  is really sophisticated please as for Help on a user mailing
> list
> Please:
> - Write a meaningful Summary describing exactly what the problem is
> - Attach a sample document (not only screenshot) or refer to an existing 
>   sample document in an other Bug with a link.
> - Attach screenshots with comments if you believe that that might explain the 
>   problem better than a text comment. Best way is to insert your screenshots
>   into a DRAW document and to add comments that explain what you want to show
> - Contribute a step by step instruction containing every key press and every 
>   mouse click how to reproduce your problem (due to example in Bug 43431)
> – if possible contribute an instruction how to create a sample document 
>   from the scratch
> - add information 
>   -- concerning your OS (Version, Distribution, Language)
>   -- concerning your LibO version (with Build ID if it's not a public release)
>      and localization (UI language, Locale setting)
>   –- Libo settings that might be related to your problems 
>     (video hardware acceleration ...)
>   -- how you launch LibO and how you opened the sample document
>   -- everything else crossing your mind after you read linked texts
Comment 5 david berndt 2012-05-14 14:20:30 UTC
Created attachment 61656 [details]
freeze screenshot
Comment 6 david berndt 2012-05-14 15:51:32 UTC
Created attachment 61660 [details]
gdb.log
Comment 7 Julien Nabet 2012-05-15 05:49:06 UTC
By taking a look at gdb.log, I wonder if the problem could be due to "lo-menubar".
Could you check if you have it installed, if it's the case, could you uninstall it and try to reproduce this behaviour ?
Comment 8 david berndt 2012-05-15 14:26:21 UTC
I removed "lo-menubar" and that seems to have alleviated my issue.  I have been unable to reproduce the issue since removing "lo-menubar"

Thanks!

(In reply to comment #7)
> By taking a look at gdb.log, I wonder if the problem could be due to
> "lo-menubar".
> Could you check if you have it installed, if it's the case, could you uninstall
> it and try to reproduce this behaviour ?
Comment 9 Rainer Bielefeld Retired 2012-05-15 21:36:15 UTC
I filed a bug on <https://bugs.launchpad.net/lo-menubar/+filebug>

@Julien: thx for investigation
Comment 10 madmuffin 2012-06-02 04:08:47 UTC
hey rainer,

i cannot find the bug report that you have reported upstream. can you provide the link?
Comment 11 Rainer Bielefeld Retired 2012-06-02 09:57:32 UTC
@madmuffin:
Seems I made a mistake (my link is some nonesense). Did a second attempt to submit a launchpad Bug, now you should find it at the "See Also" link above.
Comment 12 Rainer Bielefeld Retired 2012-06-17 06:46:39 UTC
@reporter:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and if you find out that the problem is not related to "lo-menubar"