Download it now!
Bug 49946 - landscape PRINTING result on portrait paper sheet for 2 pages per sheet (Brother MFC-J6510DW) ( THIS BUG IS BLOCKED - DO NOT WRITE NEW COMMENTS )
Summary: landscape PRINTING result on portrait paper sheet for 2 pages per sheet (Brot...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://techdoon1.blogspot.com
Whiteboard: BSA confirmed:4.1.3.2:Linux
Keywords: text:cjk
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2012-05-15 02:29 UTC by stof999
Modified: 2019-04-24 05:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
current and expected behavior (13.38 KB, application/pdf)
2012-05-15 02:41 UTC, stof999
Details
The larger image is what should print; while the smaller image shows what will actually print. (181.13 KB, image/png)
2016-08-28 10:15 UTC, Richard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stof999 2012-05-15 02:29:54 UTC
Problem description: 

with LibreOffice 3.5.3.2 
Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80

print 2 pages per sheet on a brother MFC-J6510DW:
- OOO uses by default orientation landscape. print output: sheet=portrait with 1 1/2 pages (1/2 is truncated) centered in portrait orientation.
- change orientation manually to portrait: print output: sheet=portrait with 2 pages centered in portrait orientation.

Brother_MFC-J6510DW is a strange printer! paper feed an ADF is rotated by 90° against each other.
but only the printer should be interested in that.

print 2 pages per sheet from a pdf-file printed with okular (kde pdf-reader) works fine.


Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:
sheet=portrait with 1 1/2 pages (1/2 is truncated) centered in portrait orientation.

Expected behavior:
sheet=landscape with 2 pages in portrait orientation

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 stof999 2012-05-15 02:41:02 UTC
Created attachment 61672 [details]
current and expected behavior
Comment 2 Drew Parsons 2012-06-13 21:54:06 UTC
I'm experiencing this bug too.  When printing two pages per sheet, the output is misoriented, such that the two pages are [partially] printed in landscape where the sheet has portrait orientation.  That is, the text is restricted (and truncated) to a band across the middle of the sheet.

The printing engine is not rotating the text appropriately in order to fit two pages on one sheet.

The printing error happens exactly the same regardless of the setting of Paper Orientation in the printer Properties, whether portrait or landscape is used there.
Comment 3 Drew Parsons 2012-06-13 21:59:36 UTC
Incidentally Bug #46341 sounds like the same bug.
Comment 4 Rainer Bielefeld Retired 2012-06-22 10:00:51 UTC
Works perfect with parallel installation of Master "LOdev " 3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 8d39b7]" (tinderbox: W2008R2@16-minimal_build, pull time 2012-06-20 04:38:46) and Oki 14ex (others not tested).

@Drew Parsons
With info concerning OS, LibO version, Printer and so on your Comment 2 would have been much more valuable.

@Reporter: 
that 2 pages per sheet function also is available for Calc, Draw, ... . Is your problem really limited to Writer?
Comment 5 Rainer Bielefeld Retired 2012-06-22 10:31:59 UTC
*** Bug 46341 has been marked as a duplicate of this bug. ***
Comment 6 stof999 2012-06-24 22:31:54 UTC
the problem occurs also in impress!
so involved component of reported bug should be changed to "Printing" ???
Comment 7 Rolf Gloor 2013-02-21 08:10:05 UTC
problem still exists with:

with LibreOffice 4.0.0.3  under Linux (openSUSE 12.2 with all patches)


works fine when creating a normal (non-multipage) PDF and printing PDF with Okular or AdobeReader.
Comment 8 Rolf Gloor 2013-02-21 08:24:54 UTC
PDF multipage test:

Since the build-in PDF creator does not support printing multipage, I printed a PDF using CUPS and Ghostscript.
So one could utilize the regular LibreOffice Print dialog.

There, printing 2 pages per sheet worked fine.

So the multipage printing problem persist when directly printing to (certain)  printers.


PS: Me too, having a brother MFC (MFC-8460N).
    However, multpage printing with other programms works.
    (Okular, AdobeReader, Kwrite, etc.)
Comment 9 Joel Madero 2013-02-21 18:50:38 UTC
Version is the oldest version that we see the issue, not the latest we've tested. We just use comments to say we've tested on a newer release and it's still a problem. 

Changing version back.
Comment 10 Fargus 2013-06-12 21:53:19 UTC
I confirm that the problem still exists with:
4.0.3.3 LibreOffice on Linux x86_64 and HP printer.
OpenOffice 3.3 doesn't have this bug.
I use OpenOffice to print, or (as was written above) export to pdf and print pdf 2-in-1.
Comment 11 Joel Madero 2013-06-12 21:55:14 UTC Comment hidden (obsolete)
Comment 12 Fargus 2013-09-06 20:29:33 UTC
4.1.1.2 The problem still exists. Solve, please.
Comment 13 Joel Madero 2013-09-06 20:30:43 UTC
Patches are more than welcome....feel free to dig into the code which is ready to be hacked at
Comment 14 Fargus 2013-09-06 20:31:41 UTC
4.1.1.2 The problem still exists. Solve, please.
The situation as in attachement 
https://bugs.freedesktop.org/attachment.cgi?id=61672
Comment 15 bugzilla-libreoffice 2013-12-23 20:53:34 UTC
I'm confirming this behavior persists in Draw v4.1.2.3 Build ID:410m0(Build:3). 

It does _not_ require printing 2 pages per sheet: put page in landscape mode, print -> prints in portrait mode with right side clipped. Leave in landscape mode, explicitly set printer properties page orientation to landscape -> still prints in portait mode. 

Title may need to be updated to reflect same behavior without printing 2sheet/page. 

Successful workaround: export to PDF, print from a PDF viewer. 

My printer fwiw: Brother MFC-J4700W
Comment 16 Rolf Gloor 2013-12-24 11:12:32 UTC
Fixed ?

I don't know where the problem was.
(Running LibreOffice under Linux / openSUSE 12.3)

But it looks as it has recently been fixed (somehow), either through Linux / CUPS or through LibreOffice.
I have installed all available patches to my Linux System (including apps).

The (latest) LibreOffice from the openSUSE repository is:

Version: 4.1.1.2
Build ID: 410m0(Build:2)

(Repository Version 4.1.1.2 - 1.4)

It now works with writer, calc, draw and presentation.

For me: The problem is fixed!
Comment 17 Rolf Gloor 2013-12-24 11:14:57 UTC
BTW:
It works with both of my printers:

- Brother MFC-8460N
- Samsung CLP-365

No need of PDF-work-around anymore!  :-)
Comment 18 stof999 2013-12-28 10:55:30 UTC
--NOT FIXED-- (and i guess, no one has ever done something)
with LO Version: 4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a
and printer MFC-J6510DW it is still NOT working!
Comment 19 retired 2014-01-01 11:42:02 UTC
stof999@cmdt.ch then why not just update whiteboard with Confirmed:4.1.3.2:Linux?
Comment 20 stof999 2014-01-03 06:25:34 UTC
why? because using the whiteboard, hanging off the wall, trying to scan the whole board and printing out each scan isn't so easy, but i will try.
sorry, joking aside: @foss: could you tell me something more about whiteboard? thanks.
Comment 21 Drew Parsons 2014-02-13 03:27:15 UTC
Seems to be fixed, at least I now have a successful print with 2 pages per sheet under LibreOffice 4.1.4.2 (Debian unstable), printing to HP LJ4300 via CUPS 1.7.1.
Comment 22 retired 2014-02-13 12:30:57 UTC Comment hidden (obsolete)
Comment 23 stof999 2014-02-13 13:22:29 UTC
NOT FIXED with Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba7

i don't think, this is the way of good fixing or trying to improve a product, when regularly someone is closing the task. if there someone has something done on the code, this person should know it and resolve the task.
thanks

PS: it is also NOT working with AOO401m5(Build:9714)  -  Rev. 1524958
2013-09-20 11:54 - Linux x86_64
Comment 24 retired 2014-02-13 13:46:41 UTC
Comment 21 reported this fixed. and printer bugs are hard to verify, no one has all printer models. thanks for re-opening.
Comment 25 Joel Madero 2014-02-13 15:07:55 UTC
Please don't change the version - it is the oldest version that we see the issue.

Also - the workflow works given our constraints so that's not changing unless a better workflow is proposed. If we are unable to reproduce we're going to close as WFM - it is then up to the user to follow up. Our devs cannot/will not spend their valuable time - if a QA team member cannot reproduce we close as WFM and then expect users to do their part if the bug is not fixed
Comment 26 tommy27 2014-10-17 13:25:27 UTC
--> stof999@cmdt.ch

please give an update of the bug status using latest LibO 4.3.2.2 release.
thanks for your feedback
Comment 27 stof999 2014-10-20 07:12:03 UTC
**** not resolved !!! ***

hi

with 

opensuse13.1
LO Version: 4.3.2.2 Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d
print via cups
2 pages per sheet
to brother MFC-J6510DW
Name        : mfcj6510dwcupswrapper
Version     : 3.0.0
Release     : 1
Architecture: i386
Install Date: Mit 25 Jun 2014 17:47:16 CEST
Group       : Applications
Size        : 64256
License     : 2004-2012 Brother Industries, Ltd. All Rights Reserved
Signature   : (none)
Source RPM  : mfcj6510dwcupswrapper-3.0.0-1.src.rpm
Build Date  : Don 22 Mär 2012 09:07:35 CET
Build Host  : localhost.domain
Relocations : (not relocatable)
Packager    : root@localhost
Vendor      : Brother Industries, Ltd.
Summary     : Brother CUPS Inkjet Printer Definitions
Description :
Brother Inkjet printer CUPS Driver
Distribution: (none)

LO prints the pages still as shown in the attachment <current and expected behavior>.

thanks
Comment 28 stof999 2014-10-20 07:19:01 UTC
and as a remember:

printing the odt as an pdf with okular (kde pdf-reader) 2 pages per sheet does the job as it should be.

thanks
Comment 29 tommy27 2014-10-20 07:48:40 UTC
sorry to hear that...

Brother printers are affected by multiple issues on LibO.
see this bugzilla query: http://snipurl.com/29cxibw
Comment 30 stof999 2014-10-20 09:09:22 UTC
hi tommy27

as i already told, Brother_MFC-J6510DW is a strange printer! paper feed an ADF is rotated by 90° against each other. but only the printer should be interested in that. 

KDE printing works.

what is the difference from LO and KDE printing? they use the same printer driver, cups, ...

i guess the problem could be somewhere in LO between prepare the print and sending it to cups?

can i do something more?
thanks
Comment 31 tommy27 2014-10-20 09:18:17 UTC
I have no experience with Linux so I can't help.

@Joel Madero
any ideas about this?
Comment 32 Joel Madero 2014-10-20 13:11:06 UTC
No but brother printers consistently show problems - if you do a bugzilla search you'll see quite a few hits and as far as I know we have no triagers that have a brother printer (I avoid them like the plague because it's obvious they have issues in Linux)
Comment 33 Richard 2016-08-28 10:15:48 UTC
Created attachment 127052 [details]
The larger image is what should print; while the smaller image shows what will actually print.
Comment 34 Richard 2016-08-28 10:21:59 UTC
Comment on attachment 127052 [details]
The larger image is what should print; while the smaller image shows what will actually print.

Attaching image overwrote my comment. Repeating here: 

On an HP P1102w on the following desktop,
System:    Host: h61h2mx15 Kernel: 4.7.0-2.1-liquorix-amd64 x86_64 (64 bit gcc: 4.9.2)
           Desktop: Xfce 4.12.2 (Gtk 2.24.25) Distro: MX-15_x64 Fusion 24 December 2015
Machine:   Mobo: ECS model: H61H2-CM v: 1.0 Bios: American Megatrends v: 4.6.4 date: 10/21/2011
CPU:       Dual core Intel Pentium G620 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10376
           clock speeds: max: 2600 MHz 1: 1900 MHz 2: 1900 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1440x900@59.89hz
           GLX Renderer: Mesa DRI Intel Sandybridge Desktop GLX Version: 3.0 Mesa 11.2.2 Direct Rendering: Yes

Two or four -a-page printing works as expected in LO-5.1.4 & 5.1.5;
but fails as shown in the image on LO-5.2.0.0 & -5.2.1.2.
Comment 35 QA Administrators 2017-09-01 11:21:00 UTC Comment hidden (obsolete)
Comment 36 Randy 2017-09-29 17:40:19 UTC Comment hidden (obsolete)
Comment 37 Randy 2017-10-01 15:33:16 UTC
Today I tested LibreOffice 4.3.6 on macOS Sierra and this problem was not there.
I have reverted back to this version till there is a fix.
Comment 38 Marc Ekstrand 2017-10-18 15:01:03 UTC Comment hidden (obsolete)
Comment 39 Marc Ekstrand 2017-10-18 15:02:12 UTC
(In reply to Marc Ekstrand from comment #38)
> I have this problem as well.  It started after downloading and beginning to
> use LibreOffice 5.4.2.  I use two printers and both have the same problem  a
> Brother HL-L2360D and also a copier on a network, Canon iR-ADV 4225.  The
> text created in portrait view is turned to landscape.  This shows up in the
> print preview and is the way the sheet then prints.  No changes of printer
> setting seem to fix this problem.  A work around is to change the paper type
> to A4 and then it prints in the right orientation - obviously I have to
> adjust the margins accordingly and force printing on standard paper on the
> printer end.

I should have also said I am using MacOS Sierra 10.12.6
Comment 40 Sean Gabel 2018-08-10 09:34:02 UTC Comment hidden (spam)
Comment 41 Sean Gabel 2018-08-10 09:35:40 UTC Comment hidden (spam)
Comment 42 Brother error ts-02 2018-08-11 05:14:38 UTC Comment hidden (spam)
Comment 43 jakesmith 2018-08-16 07:00:24 UTC Comment hidden (spam)
Comment 44 nikiblea 2018-09-04 10:24:36 UTC Comment hidden (spam)
Comment 45 Mark Spencer 2018-09-12 10:21:56 UTC Comment hidden (spam)
Comment 46 Dev Smith 2018-09-25 09:53:44 UTC Comment hidden (spam)
Comment 47 Roger Smith 2018-10-12 10:09:28 UTC Comment hidden (spam)
Comment 48 prem singh 2018-10-22 09:40:35 UTC Comment hidden (spam)
Comment 49 mahi singh 2018-11-24 05:52:34 UTC Comment hidden (spam)
Comment 50 Drew Parsons 2018-11-24 17:08:50 UTC
This bug has attracted a hell lot of spam the last 6 months.  I suggest closing it.  In any case I'm unsubscribing from it. The bug is now fixed for me.
Comment 51 AlexaBeth 2018-11-25 10:59:26 UTC Comment hidden (spam)
Comment 52 AlexaBeth 2018-11-25 11:00:26 UTC Comment hidden (spam)
Comment 53 Alexa Beth 2018-12-08 06:53:23 UTC Comment hidden (spam)
Comment 54 Alexa Beth 2018-12-08 06:56:09 UTC Comment hidden (spam)
Comment 55 buy generic 2018-12-17 05:56:33 UTC Comment hidden (spam)
Comment 56 Yayan 2019-01-26 08:14:38 UTC Comment hidden (spam)
Comment 57 Aron Budea 2019-02-03 05:22:52 UTC
Cleaning up after the spammers.
If anyone's still affected by this bug with a currently supported version, please open a new bug report, and add its link to the See Also field.
Comment 58 Xisco Faulí 2019-02-03 11:28:28 UTC
I'm removing everyone from the CC list so people don't get annoyed by spammers.
I'm also applying the antispam solution to this issue. Please, do not write further comments here...
Comment 59 Tech Doon 2019-02-03 13:49:46 UTC Comment hidden (spam)
Comment 60 emma roy 2019-04-24 05:30:16 UTC Comment hidden (spam)