Download it now!
Bug 50013 - SVG: Text Exported as individual letters and not as words
Summary: SVG: Text Exported as individual letters and not as words
Status: RESOLVED DUPLICATE of bug 64457
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-16 09:56 UTC by obwyulxa
Modified: 2016-05-17 13:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description obwyulxa 2012-05-16 09:56:42 UTC
Problem description: 

SVG: Text Exported as individual letters and not as words

After creating a test flowchart document and exporting it as SVG, upon inspection of the SVG file in text editor showed the word 'Hello' and 'World' to be stored as 'H', 'e', etc. as individual entries (with the respective SVG syntax).

Steps to reproduce:
1. Launch LibreOffice Draw
2. From the Flowcharts drop down list choose Alternative Process, the (second from the top left, its prettier).
3. Draw two boxes (copy/paste the first one to make it easier)
4. Label/Type "Hello" in box 1 and "World" in box 2
5. Use connector tool to link box 1 and two (set Arrow style to Arrow Head, use right hand side)
6. Export as SVG
7. Open in text editor and notice how Hello and World are now individually spelt, H, e, l, l, o ....
8. Open SVG file in Inkscape and Export as PDF, then when the dialogue appears enable "PDF+LaTeX: Omit text in PDF, and create LaTeX file
9. Examine generated .pdf_tex and similiar to 7.
10. Open SVG file, find text, replace individual letters as with something like this:
>Hello</text>></g>
(repeat for W, o, r, l, d and save)
11. Open SVG in Inkscape once again and export as PDF (with "PDF+LaTeX" enabled) 
12. Examine updated/new .pdf_tex file and notice that it is corrected.
13. Open TexMaker (or another Latex Editor)
14. Generate or edit an existing Latex document by adding 
\def\svgwidth{\textwidth}
\input{<filename.pdf_tex>}
15. Replace <filename.pdf_tex> with actual filename
16. Repeat for the other pdf_tex file to allow comparison
17. Build and observe. This will be made more clear if text size in Latex is changed.

(Please do not respond - temporary email address used, expires with 1 hour of first use)

Current behavior:
Separates words into their individual letters when not required.
Which once processed via Inkscape (pdf+Latex) and then inserted into  Latex document shows up to be not pleasing on the eye.
Thus requires manual intervention once the SVG file has been generated.

Expected behavior:
To capture entire lines/blocks of text in whole chunks when exporting to SVG. (May also affect Windows Meta File or Enhanced Meta File export as well). May also help when importing SVG files for editing text in LibreOffice Draw, Inkscape or other editors.

Sorry for the additional steps but they are 

Thank you,


Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Hashem Masoud 2012-09-21 20:14:11 UTC
(In reply to comment #0)
I can see that the characters are separate when I examine the XML file. Although I am not a document-format expert, I don't see this as a bug, as each character can have its own attribute.

Test done using:
Version 3.6.1.2 (Build ID: e29a214) Slackware Linux 13.37

Changing to enhancement (I don't think this is a bug).
Comment 2 Cedric 2015-11-06 11:02:22 UTC
I try it in 4.2 release and there is no such problem. All exported SVG words have their letters together. It looks this is an old bug already fixed.
I feel not enough confident to change the status by myself.
Comment 3 Heiko Tietze 2016-05-17 13:41:41 UTC

*** This bug has been marked as a duplicate of bug 64457 ***