Bug 50092 - FILESAVE: Wrong line and paragragh spacing when saving as Office2010 docx
Summary: FILESAVE: Wrong line and paragragh spacing when saving as Office2010 docx
Status: RESOLVED DUPLICATE of bug 48350
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: All All
: medium critical
Assignee: Not Assigned
QA Contact: Jorendc
URL:
Whiteboard: (target:4.0.0)
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-18 06:18 UTC by Michael Kleidt
Modified: 2014-03-28 07:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
original ODT file (10.21 KB, application/vnd.oasis.opendocument.text)
2012-05-18 06:18 UTC, Michael Kleidt
Details
result of "safeAs Office 2007/2010 .docx" (3.54 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-05-18 06:20 UTC, Michael Kleidt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kleidt 2012-05-18 06:18:23 UTC
Created attachment 61801 [details]
original ODT file

Saving an ODT document as Office2007/2010 DOCX file results in wrong line spacing. You see this problem, if you use a much smaller font size the the default. See attachments:

The original file contains a text in 4pt and fit on one page.

The exported document uses also 4pt font, but add 10pt after each line, so the resulting document needs 4(!) pages.
Comment 1 Michael Kleidt 2012-05-18 06:20:51 UTC
Created attachment 61802 [details]
result of "safeAs Office 2007/2010 .docx"
Comment 2 s-joyemusequna 2012-05-19 10:30:16 UTC
Confirmed with LOdev 3.6 (master - 18-May-2012 02h44 x86@6-fast; Build ID: 8b1d29b) under Windows Vista 64.
Comment 3 Jorendc 2013-02-17 18:16:33 UTC
Can't reproduce anymore using LibreOffice 4.0.0 with Linux Mint 14 x64. Therefore I mark this bug as RESOLVED WORKSFORME (not FIXED, because we don't know which commit fixed this bug).

If this bug reappears or is still present in 4.0.0 or future releases, please feel free to REOPEN.

Kind regards,
Joren
Comment 4 Michael Kleidt 2013-02-18 10:53:25 UTC
The problem is not (compleatly) fixed in 4.0.0.3:

- Open attached "original ODT file" in LO4.0.
- "Save as.." Office2007/2010 DOCX

When I open the resulting file in LO4.0, the result is OK.

When I open the resulting file in MS Office 2007, I still get 4 Pages with wrong line spacing.

It looks like LO4.0 is consistent in saving/loding the line spaces, but the behavior is different from MS Office.
Comment 5 Michael Kleidt 2013-07-26 15:06:34 UTC
Confirmed behavior of comment 4 with LO 4.1.0.4 under Windows XP.
Comment 6 Kevin Suo 2014-01-22 07:41:35 UTC
I noticed this bug today, and after further test I found the following info which may be useful:

STEPS TO REPRODUCE:
1. New writer document, type two lines of text, Save as MS 2010 (.docx);
2. Reopen with LO, shows correct with SINGLE LINE SPACE;
3. Reopen with MS 2010, show wrong with MULTIPLE LINE SPACE (1.15).

THE REASON:
* Default style of LO Writer document is SINGLE LINE SPACE, and "0" for AFTER PARAGRAPH.
* However, default style of MS Office 2010 is MULTIPLE LINE SPACE (1.15), and "10 points" AFTER PARAGRAPH, as described in this article: 
http://office.microsoft.com/en-us/word-help/adjust-the-line-spacing-between-text-or-paragraphs-HP010368776.aspx
* When export as .docx, Writer did not set the "<w:spacing..." attributes in "/word/styles.xml", as it is treated as DEFAULT by Writer.

So, in fact, not only LINCE SPACE, but also PARAGRAPH SPACE is affected by this bug.
Comment 7 Kevin Suo 2014-03-28 07:43:32 UTC
I mark this as duplicate of bug 48350:
FILESAVE: missing <w:spacing w:after="0" w:before="0"/> in new document.docx

because there is a more detailed description of this issue and a more direct title there.

*** This bug has been marked as a duplicate of bug 48350 ***