Download it now!
Bug 50240 - 3.5.4 tries to uninstall 3.3 istead of 3.4
Summary: 3.5.4 tries to uninstall 3.3 istead of 3.4
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-22 14:22 UTC by pawet
Modified: 2012-05-30 13:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pawet 2012-05-22 14:22:47 UTC
I installed Libre Office 3.4 om my Windows XP computer but I find that a new release is available. I want to install that but installation stops at deistalling version 3.3 as it can't find the uninstaller on my desktop. Libre office help says it's version 3.4.0 OOO340m1 (Build:12), when I trie to uninstall windows uninstaller says version 3.3 is installed on my computer and cannot be uninstalled as file libreoffice33.msi is missing.
How can I update?
Comment 1 Rainer Bielefeld Retired 2012-05-22 21:22:12 UTC
I believe we would have heard about such a problem if it would be a general one

@pawet
@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach screenshots (error messages) with comments if you believe that that 
  might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language, 32Bit/64Bit)
  -- concerning your installed LibO version (with Build ID if it's not a 
     public release) and localization (UI language, Locale setting)
  -- concerning LibO version you want to install (Really 3.5.4? With complete
     .msi file name) 
  –- Libo settings that might be related to your problems 
  -- Download source, if available
  -- how you launch the installing process LibO 
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts

Even if you can not provide all demanded information, every little new information might bring the breakthrough.

May be you can test <https://www.libreoffice.org/get-help/bug/> for submitting bug reports?
Comment 2 Andras Timar 2012-05-30 12:56:43 UTC
I'm afraid the installation database on reporter's computer is corrupted. It is hard to tell why. It may be our fault, it may be Microsoft's fault, or some installation process got interrupted at some stage and left garbage after itself. Anyway, it is not reproducible in our environment, so I don't think we can do anything about it. Sorry.
Comment 3 pawet 2012-05-30 13:41:04 UTC
I found a solution to this problem by using Revo uninstaller. I don't know
exactly if it really cleans up the register of all reference to
Libreoffice, but after trying to uninstall regularly it scan the register
for keys about the program that are left behuind and (after asking you if
you agree) deletes them. After running Revo Libre0ffice was not mentioned
in programs in the control panel any more and I could install Libreoffice
3.5 with no problem at all.
---
Paul Weterings
Metiusstraat 13
1701CM  Heerhugowaard
Nederland
E-mail: p.a.weterings@gmail.com
Tel: +31727431981
Mobiel: +31653411194



2012/5/30 <bugzilla-daemon@freedesktop.org>

> https://bugs.freedesktop.org/show_bug.cgi?id=50240
>
> Andras Timar <timar74@gmail.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|NEEDINFO                    |RESOLVED
>         Resolution|                            |WORKSFORME
>         AssignedTo|libreoffice-bugs@lists.free |timar74@gmail.com
>                   |desktop.org                 |
>
> --- Comment #2 from Andras Timar <timar74@gmail.com> 2012-05-30 12:56:43
> PDT ---
> I'm afraid the installation database on reporter's computer is corrupted.
> It is
> hard to tell why. It may be our fault, it may be Microsoft's fault, or some
> installation process got interrupted at some stage and left garbage after
> itself. Anyway, it is not reproducible in our environment, so I don't
> think we
> can do anything about it. Sorry.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>