Download it now!
Bug 50466 - PRINTING: Unwanted white grid inside heart and two fire squares outside
Summary: PRINTING: Unwanted white grid inside heart and two fire squares outside
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-29 08:07 UTC by kkwet38
Modified: 2016-04-30 07:33 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Make on Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7) (18.53 KB, application/vnd.oasis.opendocument.graphics)
2012-12-16 20:49 UTC, vulcain
Details
Result on PDF export (4.95 KB, application/pdf)
2012-12-16 20:51 UTC, vulcain
Details
Screencast of PDF on Evince 3.4 (217.71 KB, image/png)
2012-12-16 21:45 UTC, vulcain
Details
Print to PDF printer or paper (18.53 KB, application/pdf)
2012-12-17 10:12 UTC, kkwet38
Details
Print to PDF printer or paper (18.53 KB, application/pdf)
2012-12-17 10:20 UTC, kkwet38
Details
screenshot Win7, LO 3.6.4, PDFCreator 1.6.1 (12.02 KB, application/pdf)
2012-12-18 23:08 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kkwet38 2012-05-29 08:07:37 UTC
Problem description: 
Bad printing of objects bitmap
Steps to reproduce:
1. Design a heart with toolbar « Symbol shapes ».
2. Format – Object – Area, Bitmaps Fiery
3. Print on paper or pdf printer.

Current behavior: A rectangle full of "fiery"

Expected behavior: A heart  full of "fiery"
To note, Page Preview and Export as Pdf are OK

Platform (if different from the browser): Windows 7 64 bits Édition Familiale Premium Service Pack 1 or Windows Vista
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 vulcain 2012-12-16 20:49:20 UTC
Created attachment 71602 [details]
Make on Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Comment 2 vulcain 2012-12-16 20:51:28 UTC
Created attachment 71603 [details]
Result on PDF export

No exactly the description, but inside the heart, we have some white line. 

Some fire are outside the heart.
Comment 3 vulcain 2012-12-16 20:54:24 UTC
Sorry
I make that on Ubuntu 12.04.1 x86_64 with LibreOffice 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Comment 4 Julien Nabet 2012-12-16 21:17:42 UTC
Comment on attachment 71603 [details]
Result on PDF export

fix mimetype
Comment 5 Julien Nabet 2012-12-16 21:18:23 UTC
Comment on attachment 71602 [details]
Make on Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)

fix mimetype
Comment 6 Julien Nabet 2012-12-16 21:24:37 UTC
On pc Debian x86-64 with master sources updated today, I reproduced the problem of white lines into the heart.
Comment 7 vulcain 2012-12-16 21:45:59 UTC
Created attachment 71604 [details]
Screencast of PDF on Evince 3.4
Comment 8 kkwet38 2012-12-17 10:12:19 UTC
Created attachment 71641 [details]
Print to PDF printer or paper

Windows 7 64 bits and LibreOffice Version 3.6.4.3 (Build ID: 2ef5aff)
O.K. on export PDF
PB only with print to paper or PDFCreator
Comment 9 kkwet38 2012-12-17 10:20:56 UTC
Created attachment 71643 [details]
Print to PDF printer or paper

Sorry, it is the first time i use attachment !
Comment 10 vulcain 2012-12-17 10:28:04 UTC
@ kkwet38@orange.fr: When you talk about PDF creator, it's a software ??


For  Result on PDF export.pdf, i use only LibreOffice. I go to Menu -> File -> Export as PDF.
Comment 11 kkwet38 2012-12-17 10:35:57 UTC
(In reply to comment #10)
> @ kkwet38@orange.fr: When you talk about PDF creator, it's a software ??
> 
> 
> For  Result on PDF export.pdf, i use only LibreOffice. I go to Menu -> File
> -> Export as PDF.

PDF Creator is à software used to show the result of the print to paper.
Export as PDF can be used to hide the problem that appear when printing on PAPER.
Comment 12 Julien Nabet 2012-12-18 23:08:25 UTC
Created attachment 71774 [details]
screenshot Win7, LO 3.6.4, PDFCreator 1.6.1

On Win7 64 with LO Version 3.6.4.3 (Build ID: 2ef5aff) and PdfCreator 1.6.1 (updated today), I had the screenshot attached. (All by default options)
Comment 13 Julien Nabet 2012-12-18 23:10:31 UTC
With pc Debian x86-64 with 3.6 sources updated some days ago + cups-pdf 2.6.1-6, I reproduce only the white grid inside the heart.
Comment 14 Julien Nabet 2012-12-18 23:13:14 UTC
Roman: would you have some time to test this tracker to know the situation on MacOs?
Comment 15 Roman Eisele 2012-12-19 09:36:14 UTC
(In reply to comment #14)
> Roman: would you have some time to test this tracker to know the situation
> on MacOs?

I would like to do so, but unfortunately, I can’t test printing issues. (I haven’t got a printer, I send all my printing jobs as PDF files to some Windows machine to which a printer is connected ... can’t access the printer via network).


@ Alex Thurgood:
Could you, being our QA expert for printing on Mac OS X, please test if this problem is reproducible on Mac OS X, too? Thank you very much!
Comment 16 kkwet38 2013-03-22 10:30:06 UTC
Problem always present on Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)
Comment 17 Alex Thurgood 2013-03-24 08:38:28 UTC
Tested on :

Version 4.1.0.0.alpha0+ (Build ID: edf57013463eff6d3b40d8d5d933577f0e6cf8e)

Downloaded ODG file.
Opened in Draw.
Cmd-P to print to networked colour laser printer
Print result : fine, no overlap, nothing outside the heart shape, heart shape itself completely filled with bitmap.

Can not reproduce on OSX 10.8.2.


Alex
Comment 18 Alex Thurgood 2013-03-24 09:00:25 UTC
Confirming on LO 3.6.5.2 on Windows XP SP3

On screen within LO the heart is displayed correctly filled.

When sending to printer, Print Preview displays ragged, almost square shaped heart boundary.

Printed result is a square filled with the fire motif bitmap.


Alex
Comment 19 Alex Thurgood 2013-03-24 09:16:39 UTC
The white line grid seems to result from the placement of the tiled bitmaps (on Windows).

Tested on 2 different printers :

Samsung CLX 3175 FN Colour Network Laser
Kyocera FS C5150DN Colour Network Laser



Alex
Comment 20 QA Administrators 2015-02-19 15:38:18 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 21 pierre-yves samyn 2015-03-06 17:46:17 UTC
Hi

Still reproduced on Windows 7/64 & Version: 4.4.1.1
Build ID: b5ac74bf8683a92078a2bc8aff97d4b436af63cb
Locale : fr_FR

Exactly same steps to reproduce...

Regards
Pierre-Yves
Comment 22 Buovjaga 2015-03-07 14:01:22 UTC
(In reply to Alex Thurgood from comment #18)
> Confirming on LO 3.6.5.2 on Windows XP SP3
> 
> On screen within LO the heart is displayed correctly filled.
> 
> When sending to printer, Print Preview displays ragged, almost square shaped
> heart boundary.
> 
> Printed result is a square filled with the fire motif bitmap.
> 
> 
> Alex

Reproduced.

The white lines on the exported PDF might be dependent on the PDF displaying software. They are visible in Firefox, but not in SumatraPDF for example.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 23 tommy27 2016-04-16 07:26:24 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 24 kkwet38 2016-04-30 07:30:34 UTC
The problem subsists with versions 4.1.6.2, 4.4.5.2 et 5.0.6.1 and disappears with 5.1.3.1 (x64)
Comment 25 Julien Nabet 2016-04-30 07:32:49 UTC
Thank you for your feedback, let's put this to VERIFIED.
Comment 26 Julien Nabet 2016-04-30 07:33:09 UTC
... then close this.