Download it now!
Bug 50527 - OLE Chart Creation with missing x-values-column
Summary: OLE Chart Creation with missing x-values-column
Status: RESOLVED DUPLICATE of bug 44195
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.2 RC1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-31 02:01 UTC by Florian Reisinger
Modified: 2015-01-28 19:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (74.92 KB, application/x-zip-compressed)
2012-06-02 23:41 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2012-05-31 02:01:45 UTC
Hi!

With this 3.5.4 release (maybe before) I am unable to set the x-values...
1) Open a Writer document.
2) Insert a diagram OLE object.
3) Change the type of the diagram to "XY".
4) Try to insert some points (0.3 / 0.7); (7 / 8.5)

I did not get this working for about 20 minutes....
Comment 1 Florian Reisinger 2012-06-02 06:02:30 UTC
Changed version...
Worked with OO.org 3.2 [Win], OO.org 3.3
Also tested with LibO portable 3.4.6 [Win]
Also affected: OpenOffice 3.4
3.6 alpha also affected (All Linux x64 deb builds, [Win] = Win 7 x64 ....)

Please keep in mind: It makes XY diagrams useless in LibreOffice (when inserted as a OLE element)!!!!!!!!!!!!!!!
Comment 2 Rainer Bielefeld Retired 2012-06-02 10:54:09 UTC
Currently I only can confirm that the behavior I see with "LibreOffice 3.6.0alpha1  German UI/Locale [Build-ID: 66f01b5] on German WIN7 Home Premium (64bit) (same in 3.5.4.2) has changed to the behavior I see witu 3.3.3

In 3.3.3 Data Table of a fresh new Chart object in Writer contains a column "X-Values" as second column, what is missing in 3.6.0 and 3.5.4.

I believe this is a bug, but I never used such charts, so that I am no familiar with correct use of those charts.

Not a blocker!

@Florian:
Please:
- It might help if you attach a test kit with 2 documents with charts,
  1 from 3.3 (works fine) and 1 from 3.5 (with bug)
- Contribute a document related step by step instruction containing 
  every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
Comment 3 Rainer Bielefeld Retired 2012-06-02 11:08:33 UTC
@Florian
Please rethink your Version selection, What 3.3 did you test?
Comment 4 Rainer Bielefeld Retired 2012-06-02 23:41:57 UTC
Created attachment 62431 [details]
Test Kit

Florian did not answer, so I hijack this Report for the problems I observed. In "Samplefrom333_a_wiht345_further Tests.odt" you should find all information you need to reproduce the problem. The root of the problem seems to be that creation of Chart in WRITER documents is buggy in 3.4 and later (Missing X-values-column).

The most early available version where I see the problem is 3.4.2RC, I believe the problem came with 3.4.0
Comment 5 Florian Reisinger 2012-06-03 00:15:16 UTC
Sorry, wasn't online yesterday evening ;)

Regina (on  the DE-Discuss ML) found a workaround.

After creating an OLE diagram in Writer and after changing the type to XY you have to delete all Y-rows in the table ( At this point there are no X-values, but there should be.. ---> THAT IS THIS VERY BUG). After doing that, you have to insert a new series (It inserts 1 X and 1 Y column). A quite annoying workaround...

I tested OO.org 3.3, because I had no working LibreOffice 3.3, I will try to test it ASAP...
Comment 6 Rainer Bielefeld Retired 2012-06-03 00:21:29 UTC
Same problem (as expected) when I create a new chart in DRAW and Impress.

I believe "Bug 44195 - First row of data added to XYDiagram is interpretted as Y-Values rather than X-Values" shows an other aspect of the problem.

@Florian:
I believe no further research is required, except your problem is different; in that case please submit a new bug.

@Kohei:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 7 Florian Reisinger 2015-01-28 19:01:10 UTC

*** This bug has been marked as a duplicate of bug 44195 ***