Bug 50695 - FORMATTING: Inserted Postscript images (.eps) are shrunk vertically and look incorrect
Summary: FORMATTING: Inserted Postscript images (.eps) are shrunk vertically and look ...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-04 13:54 UTC by Milan Bouchet-Valat
Modified: 2012-06-16 08:08 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
EPS file to reproduce the problem (5.27 KB, application/postscript)
2012-06-04 13:54 UTC, Milan Bouchet-Valat
Details
PDF of attached EPS inserted into a Writer doc (note where the border is) (83.77 KB, application/pdf)
2012-06-04 13:56 UTC, Milan Bouchet-Valat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2012-06-04 13:54:52 UTC
Created attachment 62538 [details]
EPS file to reproduce the problem

This is a regression that appeared between LibreOffice 3.4.5.2 in Fedora 16 and LibreOffice 3.5.4.2 in Fedora 17.

When inserting an encapsulated PostScript (.eps) file, the image is not scaled correctly: it is shrunk vertically, with much white space at the top. The only way to get the correct scale is to cut it and to make it higher manually - but it's hard to get the correct aspect ratio right.

I'm attaching an example EPS file, but I have many of them reproducing the problem. Also have a look at the PDF of the result. ;-)
Comment 1 Milan Bouchet-Valat 2012-06-04 13:56:17 UTC
Created attachment 62539 [details]
PDF of attached EPS inserted into a Writer doc (note where the border is)
Comment 2 Milan Bouchet-Valat 2012-06-14 12:46:40 UTC
Confirmed with 3.6.0beta1.
Comment 3 Milan Bouchet-Valat 2012-06-16 08:08:22 UTC
This is actually not a bug in LO itself, but in ImageMagick from Fedora 17. I've been able to reproduce the bug with versions of LO from 3.4 and 3.5 too, some of which I knew were working in Fedora 16. Calling /usr/bin/convert on the attached .eps file, I get the exact same scaling problem.

Filed in Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=832690