Bug Hunting Session
Bug 50775 - FILESAVE: .rtf saving encoding problem
Summary: FILESAVE: .rtf saving encoding problem
Status: RESOLVED DUPLICATE of bug 48023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:rtf, regression
Depends on:
Blocks:
 
Reported: 2012-06-06 03:16 UTC by panda
Modified: 2015-12-17 12:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Attached four files. Two files in rtf format (original and edited), and two screenshots (before and after editing). (325.77 KB, application/x-gzip)
2012-06-06 03:16 UTC, panda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description panda 2012-06-06 03:16:30 UTC
Created attachment 62660 [details]
Attached four files. Two files in rtf format (original and edited), and two screenshots (before and after editing).

Problem description: 

Attaching two files. One was created by M$O http://sharesend.com/yoeuw and other one was converted by LO http://sharesend.com/9nmf5. The first file have readable Cyrillic symbols, but after opening in LO for editing and saving in the same format all Cyrillic symbols converted to unreadable symbols. Editing was made on Linux and Win7 with the same results.

Steps to reproduce:
1. Open rtf file created by M$ Office Word
2. Make any changes (I changed few symbols of date in the document)
3. Save it in rtf format.
4. Close the document
5. Open it again.

Current behavior:

It is a ruins against Cyrillic symbols. 

Expected behavior:

No encoding changes expected.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 panda 2012-06-06 03:20:26 UTC
Editing was made on Linux Ubuntu AMD64 and Windows 7 32 bit platform with the same results.
Comment 2 s-joyemusequna 2012-06-06 11:14:16 UTC
Unable to reproduce the bug. Tested with LibO 3.5.4 and with LOdev 3.7 (master - 06-Jun-2012 04h12 x86@6-fast; Build ID: b255de8) under Windows XP and Windows Vista 64.
Comment 3 Urmas 2012-06-23 07:42:40 UTC
Designers of "M$O" are not рукожопые макаки who cannot read specifications for shit, unlike LO's ones.

Meanwhile, you can fix that document by removing "\f7" from document body and the font table (the entire {\f7\.....} fragment inside "\fonttbl".
Comment 4 Urmas 2012-06-23 07:48:00 UTC
Confirmed in 3.5.5, BTW. I'm pretty sure there's a duplicate bug erroneously closed by some fanboy.
Comment 5 panda 2012-07-31 11:44:03 UTC
(In reply to comment #3)
> Meanwhile, you can fix that document by removing "\f7" from document body and
> the font table (the entire {\f7\.....} fragment inside "\fonttbl".

Thanks a lot friend! It's worked like a charm!
Comment 6 Miklos Vajna 2012-08-01 10:55:32 UTC
Just like s-joyemusequna, I can't reproduce this, either (tried with master, -3-6 and -3-5). Can you post the output of the 'locale' command on Linux? Just in case you have something special there.

Thanks.
Comment 7 wxx 2012-08-28 13:19:11 UTC
Currently I am generating the rtf file in in house software. This file opens properly in Microsoft office.
RTF file opens in libre office but scattered data.
I dont want to change the format of the file.
Please help me on this line.

I tried the rtf format using Open-Office but problem remained same. These formats were clearly seen in Microsoft Office.
Then what may be the problem in open office and libre office

Thanks in advance.
Comment 8 Michael Meeks 2012-10-22 14:52:48 UTC
Hi Panda,

Thanks for the fantastic bug report, complete with test-kit images, etc. very much appreciated. If (as we suspect) this is a duplicate of bug#48023 - then it is fixed in 3.6.x. It'd be great to verify that is so - at least, we cannot reproduce it here anymore.

wxx:
> RTF file opens in libre office but scattered data. I dont want to change the 
> format of the file.

This sounds like a different issue to the encoding problem that Panda filed for this ticket. To avoid confusion it would be great to file a new issue of your own with a sample document and a clearer explanation of your data scattering problem, preferably vs. 3.6.2.

Thanks for using LibreOffice & reporting bugs.

*** This bug has been marked as a duplicate of bug 48023 ***
Comment 9 Robinson Tryon (qubit) 2015-12-17 12:06:46 UTC
Migrating Whiteboard tags to Keywords: (filter:rtf)
Replace rtf_filter -> filter:rtf.
[NinjaEdit]