Bug 50797 - FORMATTING: unexpected behavior when hiding rows
Summary: FORMATTING: unexpected behavior when hiding rows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-06 13:22 UTC by baldinirobert
Modified: 2016-02-22 08:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Here you see the unexpected behavior when hiding cells with graphical object attached to them (16.94 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-06-06 13:22 UTC, baldinirobert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baldinirobert 2012-06-06 13:22:17 UTC
Created attachment 62681 [details]
Here you see the unexpected behavior when hiding cells with graphical object attached to them

When a graphical object is inserted into a table and attached to a cell, putting the row of the cell invisible will not end in an invisible graphical object.
In MS-Excel it's possible to indicate that the position of the grafical object depends on cell-position and cell-dimensions. So when the cell gets hidden, the grafical object gets hidden too, This would be an expected behavior for me.
Comment 1 Joel Madero 2012-11-28 17:38:38 UTC
I can confirm this but what I can't confirm is the properties of the inserted object as I can't actually select it -- very strange, wondering if this is a bug in of itself.

For this though I am going to mark as NEW

Normal: Can possibly prevent high quality work under very specific situations. No workaround

Low: Very specific situation only, not going to affect a lot of people
Comment 2 QA Administrators 2015-01-05 17:50:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 3 Buovjaga 2015-01-19 12:09:57 UTC
Image hides ok, if the row height is bigger than the image.

It seems the hiding is achieved by shrinking the height of the image?!

If the cell-anchored image is twice the height of the row, hiding the row will squish the image to half-height.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 5f6bdce0c0ac687f418821ce328f2987bf340cda
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 0ffa3abc7d6c0437ece30cfb1430d28ffcc9f5c1
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-15_22:47:16
Comment 4 QA Administrators 2016-02-21 08:34:15 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice 
   (5.0.5 or 5.1.0)  https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and 
   your operating system, and any changes you see in the bug behavior
 
   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
   appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21
Comment 5 baldinirobert 2016-02-22 08:29:21 UTC
testet on windows7 and libreoffice 5.1.0.3. now, if the image lies completely in the cell, it gets hidden too when the cell gets hidden.
Comment 6 steve -_- 2016-02-22 08:44:04 UTC
Since there is no specific commit fixing this issue, setting to WORKSFORME. FIXED is used only when a commit exists.