Bug 50815 - WebDav access broken under Windows
Summary: WebDav access broken under Windows
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 00:24 UTC by Flemming from Banana hill
Modified: 2013-08-30 16:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Flemming from Banana hill 2012-06-07 00:24:07 UTC
Native WebDav works as expected under Linux (Fedora 17 x64 & LibreOffice 3.5.3.2). When a webdav path is entered the username and password is requested.

However, under Windows Windows 7 (x64) with LibreOffice 3.5.4.2.) when a WebDAV URL is entered in the "File open", "File save" or in the "Tools" -> "Options" -> "LibreOffice" -> "My Documents" path a message box pops up with the information:

 Nonexistent object.
 Nonexistent file.

If a LibreOffice application is opened from the command line with a document stored on a WebDav server it behaves as expected. Based on this the following workaround can be devised:

1) In "LibreOffice Writer" go to "Tools" -> "Options" -> "LibreOffice" -> "General" and select "Use libreOffice dialogs" under "Open/Save dialogs"

2) Open the LibreOffice personal settings file "%APPDATA%\LibreOffice\3\user\registrymodifications.xcu" for editing in notepad or another editor. Find the variable "<prop oor:name="WritePath" oor:op="fuse"><value>$(work)</value>" and change the "$(work)" part to the path to your WebDav server.

3) Save an empty document as "ODF Text Document Template (.ott)" and upload it to the WebDav server. Notice the full path, e.g. "https://webdav.bananahill.net/home/webdav.ott"

4) Modify the "LibreOffice Writer" shortcut to include the full path to the uploaded template document from the previous step. One way to do this in windows 7 is to type "LibreOffice Writer" in the start menu; right-click on the shortcut and select properties. Add the path of the documentto the end of the Target line so it looks something like this:  "C:\Program Files (x86)\LibreOffice 3.5\program\swriter.exe" "https://webdav.bananahill.net/home/webdav.ott"

5) Repeat step 3 and 4 for each LibreOffice program that needs WebDav access.


With this setup the "Default Dirctory" button (the one with the house) in the "file save" and "file open" will take you to the WebDav server. To go to a local partition just type the partition letter in the "File name" box, e.g. "C:" and press enter.
Comment 1 bureautiquelibre 2012-11-06 11:17:14 UTC
I can confirm this bug on windows XP with LibO v3.6.3 trying to access a WebDav with basic or NTLM authentication enabled.

I get the same error message.

Best Regards,
Eric Ficheux
Comment 2 tommy27 2013-08-29 13:19:52 UTC
do you still have this issue with recent 4.0.5 or 4.1.1 LibO releases?
Comment 3 Flemming from Banana hill 2013-08-30 14:03:12 UTC
The problem is still present in LibreOffice 4.0.4.2 and 4.0.5.2 under Windows XP 32bit. Trying to open a file on webdav gives the error message: "xxx The above file name is invalid."

However, I just came across Bug 14786 (https://issues.apache.org/ooo/show_bug.cgi?id=14786) that is related. It explains that the limitation is with Windows and the solution is to enable the LibreOffice native file open/save dialogue: 'Tools - Options - - General - Open/Save dialogs'. I can confirm that this works.

Since it is not an issue with LibreOffice I have marked it as NOTABUG.
Comment 4 tommy27 2013-08-30 16:47:54 UTC
so NOTOURBUG fits better than NOTABUG.